I can't get Yafray to work

I’ve seen some of the awesome renders done with yafray and I wanted to try it, but I can’t get it to work and yes I did download and install it. When I render, it just renders a black image in 0.25 seconds. I’ve tried turning up the gamma and exposure but nothing seems to work. Any one able to tell me what I might be doing wrong?

Yeah. What you’re doing wrong is writing thread titles is such an absolute fashion. “Yafray won’t work.” Yafray does work, as you pointed out in your post. How many people who use and like Yafray are going to look at a thread title like that and just pass on by? How about telling the truth in your title? “I can’t get Yafray to work” or “My Yafray scene renders all black” if the first one is too threatening to your tender ego.

There’s also a strong possibility you don’t have a light in your scene that Yafray recognizes. At least, if it quits quickly, it has checked out the scene and decided there’s nothing to do. Yafray posts notes in the console. Check it out.

This is what the console says

Attachments


BUMP

Still need help

Does it make any difference whether you have the XML button selected or unselected on the Yafray tab (under Render settings)?

The Yafray tutorial said to have that selected, but I’ll give it a try thanks

Thanks Dich, it worked :slight_smile: exept when I try and render a high detail model/scene it crashes. any hints?

AFAIK: If XML is off, then Yafray is called as a plug-in for blender and basically renders “in” blender. If the XML button is on, the scene is saved as a Yafray XML file and Yafray itself is run using the XML file. My guess is that some environmental variable for Yafray is not set. Check the Read.me file in the Yafray folder on your comp.