i can't open upbge

i all, i just downloaded the latest version of upbge (v0.2.0b2.78) zip file for windows 64bit
i tried to launch it but an error said i cant open it cause msvcr120.dll was not found so i downloaded the dll and pasted it in system32, sysWOW64 and upbge folders.
before that i unistalled all visual c++ i found in my unistall panel and installed the lastest visual c++
now the error is different it says something like “impossible to open application (0x000007b)”
any help?
thx

wow. you downloaded the dll. just wow.

you need vc redist 2008, 2010, 2012, 2013, 2015. both x86 and x64. i install for 2005 for sketchup 8. make sure you get the latest updates to those.

@giobbo: hello, it seems we have an issue with our cmakelist. You can download BF Blender official https://www.blender.org/download/ and copy the following DLLs in you upbge folder: msvcp120.dll, msvcr120.dll, vcomp120.dll

(it seems it was my version of cmake which was too recent)

thx youle, i already did it but for some reason it didn’t work, now it works