I cant see indexMA

Hi guys,

i have render of kitchen and there are some lights. So i set for emision material ( i have 2 materials - basic is shader of lamp and second is asigned emision material ) pass index 1. In render layer i set Material index but when in compositor separate this index it doesnt work. Compositor I set like this http://www.blenderguru.com/wp-content/uploads/2013/11/521.png

Thank for help

Post your .blend file (http://www.pasteall.org/blend/ and share the link) or screenshots where you have material with its index visible, renderlayers with passes visible, and compositing nodes you use. Having blenderguru example node setup means nothing in terms of knowing what’s wrong with your setup.


There is it. I still can´t see what is wrong but probably i did mistake

Can’t replicate the problem


You sure are making sure the minimal amount of information is coming through.
For the looks of it, index is not visible in the compositor like already noted. As of why, no idea. All seems to be fine in your settings.
If you enabled Material index pass after rendering, that could be one reason why it doesn’t show up. Have to render again after enabling passes.
You seem to be running an old version of Blender (on Windows for what I can tell from the image EXIF data). Maybe the problem is related to that somehow. Perhaps get a new version and try that.

If that doesn’t work, prepare a test file where you have the object (or parts of it) with the lights you’re trying to add the glare to. Also other objects that are required to make those visible in the render, obviously. That way others can test it properly and see what other setting could be wrong (if any). You would need a test file for reporting a bug too, but that will require to test with the latest Blender first.

Thank you,

I use 2.63 because I found this version with support of old CUDA ( 1.2 ) and I need fast rendering for this work. I try it on new version and it worked. So I must use 2 render layers for glow. Nevermind.

have a nice day :slight_smile: