I cant select bones directly in weight paint mode in Blender 2.8

In blender 2.79, i just had to put the armature in pose mode, tab out, the go in weight paint mode on the mesh to be able to select the bones and its respective weights on the mesh. As far as i could see, you cant select bones on the armature from weight paint mode on the mesh… is there a new workflow?
i could not find anything on this issue, so i am assuming im missing something quite basic.
Thanks in advance

I had the same issuev earlier this week…hold down the Ctrl button and select. Took me a while to figure that one out.

but are you using 2.8? i am aware of this, but it still doesnt work

2.79 here, selecting bones in weight paint mode is working well. No idea what’s wrong in your blender. Try to download fresh blender and try it, it should work.

i think i didnt comunicate well, my 2.79 works normaly, but i want to use 2.8, and its apparently not possible to do this.

1 Like

Ah then ok, i just misunerstood you. Hope they will fix it in 2.8. Maybe you should report this issue.

1 Like

i thought that this being such a basic thing, it would be either already reported or that i would not know of some specific workframe.
i will be reporting this now

Yep it works in my 2.8 build. Maybe something broke between builds? Have you tried downloading the latest one from the website?

i will do that now and report

Ok great. I’m traveling but when I get a chance I’ll double check it on my end too. :slight_smile:

Hi, you have to go to Edit -> “uncheck” Lock Object Mode -> profit!

6 Likes

Thanks! that was it

In 2.80.74, In Weight Paint Mode, while hovering over desired bone, Shift + RMB does it.

I did not find (yet) the “uncheck Lock Object Mode” mentioned earlier.

I was having trouble with this but finally realized I needed to:

  1. Select mesh
  2. Go to Modifiers (Wrench Icon)
  3. Add an “Armature” modifier
  4. In the new armature modifiers tab under “Object:” select Armature.
  5. Happy Rigging

Hopefully this helps those as noob as I.

guys. please check my video. I have solved this ploblem all going back to normal as weight paint mode should work :slight_smile:
Blender 2.8 _ Cant select bone in weight paint mode FIXED!!!