I got a problem with strange looking edges in edit mode

Hello, here’s my first post and i need help.
Wideo of a problem: http://puu.sh/qYIsS/437022170b.mp4
The strange looking lines which i’m pointing on this wideo with cursor are there in edit mode, which they should’t be - this short ones, which should be hidden, because i have disabled option - visible through walls.
I set something in options for sure but idk what cause this.
Help me, thanks in advance.

Is your scene very very small or very very large
Use the default viewport start and end clip distances. Scale your scene if required


Clip end set to 1000 does the the trick, thank you :slight_smile: