I hate texturing spheres in the BGE

and I’m not talking about unwrapping a panorama to a uv sphere, I’m talking about when I have a texture, any texture, on a sphere with backface culling disabled, this happens:

why the fuck does it do that

That happens In any engine.
Just use back-face culling when using transparency…

This reminds me of a problem I had with alpha sorting. The only fail proof solution I could find for my problem was splitting my mesh up into smaller chunks. Perhaps you could split apart the mesh into smaller pieces and parent them all to an empty in the center of your sphere where the origin would be?

You could just duplicate the faces after re enabling transparency, and flip the normals of the duplicated sphere. The mesh would have twice as many vertecies, but I think it’s almost as expensive as rendering twice the number of faces with back face culling turned off…

Tried that. Didn’t work.

This seems like a better idea

Take some time to understand why this happens. Then it’s easy to avoid/fix/design solutions to.*
Also, try changing your material through the different alpha blend modes - one of them will (or at least should) fix it.**

*hint: how does the computer know the rendering order of faces?
**Seems there’s a bug in the viewport that means it only works when you’re in-game.

I have gone through all the blend modes before and the only one that seems to work is “Add” but then it becomes bright and nasty to work with.

to fake a depth effect, you could use a dot product of the view and normal vectors, or set a radial gradient texture to “normal” instead of uvmap coordinates. fresnel node works too, but i personally find it harder to work with.

This is an easy one.
Enable backface culling.
select the whole mesh, duplicate it, flip the faces.
Now you have two meshes with backface culling, one inside facing one outside facing.
Same performance as turning off backface culling.