I have a problem with light on individual layers

For some reason, light objects work only on the first layer.
001

003

The second layer here has Environment lighting and the sun object does not affect the scene on this layer at all.
But when I create a new scene, the light objects work on every layer.
What might cause this problem?
Is there a settings option where I can disable light objects in specific layers?

Yes, there’s an option for lamps : uncheck “this layer only”

The problem is I have it unchecked already.
004

There are two potential causes that may be causing the issue:

  1. Perhaps you accidentally restricted your layer 1 materials to a certain light group:

  1. I notice that while you are selecting objects in layer 1 & 2, your layer 2 is “not” active. Lights need to be active in order for their lighting to affect other active layers.

image

1 Like

I have an example from a newly created scene where I use one light object on 3 separate layers.
It works fine here but for some reason, no light object works in the previous scene except for layer 1.

The thing is that I’d like to create objects in separate layers while using the light source, but it doesn’t work.

And I didn’t find anything about restricting materials for layer 1

Can you share a minimized, reproducible blend file?

1 Like

I might try to cut some stuff but I have a lot of code and packed in textures.

Ok, here is the cut-down version, thanks for wanting to help.
ForkLift_0.73_CUT.blend (3.3 MB)

Problem solved. Your second layer was turned off in your scene’s render layers.
Note: You’ll need to switch to Blender Render or Cycles in order to fully access the Render Layers panel.

Wrong way (layer category)

Correct way (layer category)

Thank you for your advice.
The thing is why can I use the light object in another scene without turning on layer one?

Because “all” newly created scenes have render layers enabled by default:

You can disable the ‘lock camera and layers’ option to use the viewport layers rather than the Render layers:

disable

Thank you, this is what I was looking for.
I must have clicked on it by mistake and didn’t know what it actually does.