I have a strange orange dot on my mesh? Can anyone help me figure this one out?

I must have hit some wrong key at some point. But all of a sudden I noticed a small orange dot, like a selected vertex, that appeared at the top of the head of my mesh. It is not a vertex because i cannot select it. I have some pics showing it with my sub-division modifier on and off. In the one with it on, I have a vertex selected but you can see the strange orange dot inside the white circle just outside of the mesh.

Thanks for looking. Any suggestions on how to get rid of it?


You should have also uploaded a .blend file. That way you’d have a better chance of solving your problem.

My guess would be that it’s an object that you’ve managed to select in Edit mode of your character. Exit out of edit mode of your character and check in your outliner how many objects you have, or you could just press A to select everything in your scene and see what poops up. Note that, that small object probably has it’s origin point set at the same place as your characters head.

I laughed out loud when I hit tab to go back to object mode…and sure enough it was it’s own object. Thank you Ognjen for taking the time to indulge me in learning what should have been obvious. It is a lesson i will not forget. I still can’t believe I didn’t do that before reading your reply. Very grateful!

looks like origin of the object
located there to use the mirror modifier

happy bl

Thanks Ricky. Not sure as I have deleted that little dot.

there might be a set up in user preferences!

or you have re assign the origin some where else

do you still have the mirror modifier ?

happy bl

I still have an origin point. I know the attachments were small and hard to see but I had the origin set to the center of the world grid. So it was not the origin. Yes I still have the mirror modifier on. But the strange object is gone from the scene.

next time upload the file so we can see it

and might be able to ID it then

happy bl

Will do…thanks

For future reference, you can see in the outliner on the top right that you have 2 objects selected.

Thanks DCB That is precisely one of the things I have learned in this thread.