I have tried everything I could find on the forums, but I cannot get this to work.

I have for a long time thought that my computer simply can’t do this, but I recently found and imported someone else’s model that works perfectly for me, so I know I can.

The problem is I cannot get transparency to work in Texture Paint in the Viewport at all. The model I imported did not have any materials at all that I could see, and the texture supplied was a PNG file with transparency, so no Alpha Channel support.

How was this done? If I could actually get PNG transparency on texture files to show as transparent in Texture Paint, without the use of Materials nor Alpha channels, it would be a huge help.

Image assigned to faces in UV editor will show transparency if you stay in Solid shaded viewport and enable Textured Solid in properties region, Shading panel. But the transparency will still go away if you switch to texture paint mode and set painting mode to Image. I.e. you will need to have a proper material set-up to see the transparency, so I’m not totally sure what exactly are you asking.

If I understand your question properly, the solution has to do with the way the .png images are imported.

I use the “import images as planes” plugin and the following settings during the import:

  • Use Alpha
  • Premultiplied
  • Shadeless
  • Z Transparency

When I do this, I have .png images with transparent backgrounds when the 3D viewport is set to texture mode.

I am not sure if this will help with your painting issue, but at the very least here are the (thirteen) steps required to display transparency in the Blender viewport.

I hope this helps !


Here are the workflow for Cycles Render.

Use…Add - mesh - Import Images as planes…For your Tansparent file.

In file browser left panel - Import Images as planes - click use alpha if it isen’t on.

Below there are the material Settings box ( Cycles ) Click Diffuse & Transparent.

It’s now set up to use transparent - see nodeset up in picture - And ready to use in texturepaint.

Thank for the explanation for the Blender Render set up…:slight_smile:


Thanks for the replies everyone. Unfortunately, I forgot to mention in my first post that I use 2.49b, so most of the advise gotten doesn’t apply, as I simply do not have those options.

I am downloading and will try 2.74 to see if I can get this to work, following all of your advise, and will post if any actually work for me.
Thanks a bunch :slight_smile: