I hit pkey and now my renders hate me!

I’ve been working on some orthographic scenes for a game project that I’m working on with a programmer buddy. Specifically, a forest. I had created a large portion of my art assets in a single save (oh god I’m such a fool) and then today, I hit the pkey. I was unaware that this turned on the game engine and once my menu bars all turned black I thought that blender was crapping itself. I panicked, saved, restarted and thought all was well. I did a bunch more work and then went to render.

Now every time I attempt to render, what would look like this:

Now looks like this:

I’ve tried to append objects from the broken file to other files where it still renders with working textures, but they still render as though they’re in a winter wonderland. If it helps, in object mode when textures are displayed everything turns a bright pink.

I’m running blender 2.62. Please tell me there’s some way of getting the textures to show up in renders again.

This is the only thing I can think of, but make sure shading is set to GLSL. That’s the only thing I can find that switches off textures.

Good luck!

Sorry, I wasn’t specific enough. I never intended to do the render using blender’s game engine. What I’m trying to do is get the best renders my 3 weeks of total blender experience can provide and then make a faux 3d game using bitmaps.

I hit pkey on 3d view accidentally when trying to type “palm tree” into an object group and now blender uses the game engine rendering process and I can’t figure out how to go back the way it was doing it before.

And if you’re curious, i tried GLSL shading anyway and while it probably would’ve worked if I had everything set up to use game engine, it didn’t here. Thanks for the suggestion though!

If in object mode something goes nice bright pink, blender has lost idea where textures came from. Correct me here?
Try to point to a corresponding texture files on hd in Texture panel, reload them from HD.

I took your advice and gave the textures a second glance. For some reason game engine/blender decided to make a clone of my texture folder for the game engine thing without any of the textures in it. It then changed the source for all my materials to draw textures from this empty folder.

This particular save file still behaves a little bit oddly but with that information I was able to append objects to another save and relink the textures successfully.


(I guess this thread is now in the wrong forum isn’t it…)