I just cannot post anything

Hi all!

I am making here a try, because I have worked on a thread in the Work in Progress section and after abou 30 minutes of structurating it properly, I pressed Submit New Thread and nothing at all happened, my post just dissapeared and after a few hours it is just lost…I tried to post some comment on other threads and the outcome wast the same, seems that I cannot post anything here…

You might want to have a look at the forum rules (top menu bar, under “Site Help”):
New users’ first 10 posts need to be moderated before they appear on the forum - this is a spam bot prevention system.

Ah, ok, now I saw, the reason is that I didn’t saw that info that appears after you post something because it dissapears very fast, but at the last post I managed to see something and now I understand what was happening.

As has been noted, please note the Forum FAQ. Most of the time, new posts don’t sit in the queue for more than 24 hours. Please be patient with our moderation team.