I know the function to set the physics TicRate, but how do you get it to work?

So I have an object that has an always sensor connected to a python logic brick that has this code

 
import GameLogic
GameLogic.setPhysicsTicRate(180.0)

How do I get the Physics ticrate to actually change so the object in my game can safetly do high speed collisions without going through objects, I must be doing something wrong because there’s no effect even with the rate set to 1000. I even tried copying from the tutorials for Blender 3D site where they described the function but it had no effect on my game. I also tried copying the functions to get the controller and owner from other scripts but that didn’t work either.

any error in the module’s window?

I’ve looked in the module window but I hadn’t seen any error reported, I don’t know what could be the problem.

Make sure the always actuator doesn’t have pulse mode on.

are you sure there is something to do with collision detection ?

There is some issue to handle high speed collision … Like reducing the size of models … I don’t know if you’ve alredy try it but it worked for me

I tried setting pulse mode off and something wierd is afoot.

Sometimes it seems to work and sometimes it doesn’t, I start a hole, slam the ball into something at high speed, and it bounces off but when I do the same shot after quitting and starting again it goes through.

I don’t know what, this may or may not be a bug, perhaps a future feature would be that the ticrate settings are per object and you can set them in the physics panel.

do you have any other script that might reset the default physic tic rate in your game?

You might need to ‘enable all frames’, but that might only effect the logic tic rate…

~~Stu

What I’ve found is that the GE can only go as high as the refersh rate that is set for your card. You have to set the refresh rate higher to go higher.You can go slower though.

Also use setLogicTicRate(180.0)

EDIT

I’ve been playing around with this a bit and i might be wrong. i cant tll on this old machine, it will only run at 60.

Logic ticrate and pysic ticrate are computerized the way you set it whatever the “refreshing” tic of your computer graphics have. rendering the graphic is totally diferent from computerizing the logic and physic. even if you put 120 ticrate for the physic, it will go calculate 120 time per sec, you wont see 120 frame per second of course put the pysics will be more accurate coz even if you actually “see” 60 fps, the computer still run your physic 120 per sec.