I literally used game engine for the first time 20 minutes ago. Slow motion?

basically I’m making a simple physics thing, and all of my objects look like they’re in slow motion. How can i fix this?

Change the animation frame rate or FPS.

It’s at like 100, what do I m,ake it to make it go faster?

What is too slow? Gravity?
You can try scaling all your objects down so they look like they move faster. Bear in mind that one blender unit is one meter (or about three feet)

Have you ever tried to disable “Enable All Frames” option in the menu game?

I suggest looking into the physics tab and editing the maximum or minimum velocity. I also used the dampening function to make explosions similar to ones from inception, where the objects start off fast and finish stopped (similar to physics under water).
otherwise animation would be your best bet.

I’d suggest posting a blend, there are way too many ways that this could be happening. If none of the other posts are working though, I would check your poly count. Maybe you have several high poly objects with triangle collision detection or something :smiley:

whoops sorry i read the thread wrong, i agree with Spike1 a .blend would be helpful. Also check your computer specs.