I made an oopsy!

Okay, so I made a problem in Blender. I recognize the problem, but I don’t know how to fix it without making a mess. What I did was I added an armature to a mesh of mine. I weight painted it, and made a running animation with it and everything seemed fine. When I tried to use the animation in the game engine, however, I came to realize that I had never parented the armature and the mesh together. When I try to do it now, it messes up my mesh (although the animation does now work in the game). If I clear rotation and location in pose mode (because these were considerable altered when making my running animation), my mesh returns to its normal self, but if I try to run the animation, or move the armature in any way (in pose mode), things get strange. For example, if I rotate the arm of my armature then the arm of my mesh rotates as well, but at a different rate, and the two do not move together. Also, the entire mesh tends to be torn in a not-so-pleasant way (I’ve included a pic). I’d love to know what is going on and how to avoid this in the future. Any help?

Attachments


Try selecting the mesh > Alt + P and select clear and keep transformation. Then re parent the mesh to the armature. Try posting a blend.

hope this helps

Hmm, that sort of worked. Now the animation runs in a more usual way, but there is still some odd stuff about it. It almost seems as if it has been rotated 180 degrees, although I don’t think that that is what it actually is. Anyway, I’m including two links to two .blend files. The first is from when the armature and mesh were not parented but the animation ran smoothly, and the second is where they are parented the animation does not run well.

Not parented: http://www.filefront.com/14305479/animationTest.blend/
Parented: http://www.filefront.com/14305041/animationTesttest.blend/