i messed up something with my paintbrush?!

GOD HELP ME
i was trying to get back the option of not changing the size of the brush with tablet pen pressure in texture paint mode, but i didn’t find it, and when i got back to painting my brush did something like this



i don’t know for sure what i did? i just want to make this smoothing feature to disappear, and also make my brush always the same size (in the image you can see the stroke gets bigger towards the end, that0s what i mean: i want to have strokes always the same size)
thank you
please help me it’s sort of urgent

I believe you turned on smooth stroke. Just uncheck it to go back to normal.

it’s already unchecked actually. i saw i had checked it, so i unchecked it but the smoothing tool won’t go away…