I need Blender 2.25!!!

I just started using Crystalblend and everyone says that blender 2.25 works best with it. But everywere I find a download link it says that it can’t find its server. I guess because the links is so old. CAN ANYONE HELP ME FIND BLENDER 2.25?

http://download.blender.org/release/Publisher2.25/

Thank you “z3r0 d” you are #1.

everyone says that blender 2.25 works best with it.

Rumors!!! :wink: Lol, well it probably is the most compatible because CrystalBlend is still relatively new. Hehe, since 2.25 has less options than the newer versions of blender it would probably be the most compatible since not everything is implemented yet in CrystalBlend.

Jason Lin