I need help please: Blender suddenly won't complete the rendering of an animation

Hi everyone, this is my first post. I joined the community because i love blender and after 4 months i keep using it non-stop i encountered an issue, which i have no clue about how to resolve.
I’m trying to render an animation of a landscape i created, with 96 frames: when i start the rendering, everything seems to be fine, but after a few frames (10-12, sometimes even less, it’s quite random) the render screen won’t show the next frame processing, cpu usage will start going 100% (even if i tried already rendering GPU only) and it will just freeze on the last frame rendered. At that point Blender won’t respond anymore and it will force me to terminate the application.
I already tried reducing the amount of frames rendered to like 24 but nothing changed, same problem occured.
What scared me is that when i tried to render some old animations i had already rendered weeks ago, the same problem occured and Blender couldn’t manage to compile the animation neither. As if it’s been corrupted or so.
I tried uninstalling my Blender version (2.92) and since it just came out the last 2.93 i tried installing that one, but the problem persisted anyway. I don’t know if i need to clean the registry or do something else to fix the issue. I’m quite at a loss of options and kinda desperate as i really need to be able to render animations for a project i’m working on.
My rig is composed by:
CPU: I9900K 3.60 GHz
GPU: nvidia 2080ti rtx
RAM: 32 GB

Let me know if you guys need other information or files, and i’ll make sure to provide everything i can.
Thanks in advance for whoever will take some time to help me.

1 Like

How big is the file? Have you tried with persistent Data option?

Is one of your hard drives full? Check if console rendering is working for it.

Tried rendering a totally different project to see if the problem is there?

How long do you wait for blender to respond again?

Hey schamph! I’ll try to follow the order of your questions:

  • The file is 56,7 MB at the moment as there is a 200x200 m landscape with loads of different materials and objects. Rendering of a single frame takes about 40 seconds with Cycles and Optix rendering.
    When i tried with Persistent Data option rendering froze after the first frame already.

  • i have blender installed in my SSD which currently has 116 GB of free space, but i keep blender files in the other hard disk and HDD which currently has 2,18 TB free. How do i check console rendering?

  • i tried rendering another animation (even much much lighter in terms of polygons count) that i had already rendered fine weeks ago. It’s a character animation of about 100 frames. Now it froze after a bit more than 70 frames had been rendered. :frowning: this never happened before in 4 months of use, both in 2.91 and 2.92.

  • The thing is that when render freezes and Blender doesn’t respond, CPU usage goes up to 100% and i don’t wanna risk to damage it, so i force quit after max 5 minutes of waiting.

You mention registry which makes think of WIndows. I Have seen recently a windows 10 machine that was crippled attempting to constantly try auto updates, it was using 100% hard drive i/o and cpu was very high. Start a render and keep the task manager open and see is any processes have huge memory consumption, or if certain process are trying to write to disk. IF you see ‘win updater’ or similar, kill the process and do your windows updates manually (takes an hour+ or so) if it’s not that just keep watching all your metrics and try and see what’s happening.

Also are you rendering still images, or rendering directly to a video format?

Hey Tim, yes i am using windows 10 and i made sure it was everything up to date. When i tried a rendering with task manager opened i could see that gpu usage was barely using up to 7-8% while cpu was going up to like a maximum of 65% or so. Then when the render froze it went up to 100% :man_shrugging:t3:
I already tried both rendering single png images sequence and mpeg4 video codec but i got the same results. It freezes randomly within the first 12-15 frames.
I’ll try remove automatic updates from windows, but i fear that won’t change that much, as everything worked fine up until yesterday afternoon and then all of a sudden everything went [email protected]#*d up…

As a sanity check, try closing bkender, reopening andvrendering a single frame, the single frame that it crashed on preferably.

100% cpu utilization on all cores is actually normal in many circumstances during a render.

Try powering diwn and re seating the gpu and memory etc, make sure power cables to gou are firm. Since it’s windows you might want to light some incense and say a small prayer.

1 Like

Yes 100% usage for Cpu on rendering is pretty normal. It not damaging it, its normal use…

You said every frame alone is rendering fine? Then maybe try the sheepit renderfarm. They are splitting it and your file is not so big…

may be try command line aswell, had to use it for some animations.
blender.exe -b blenderfile.blend -a
for rendering the animation according to the .blend settings

can limit threads number with -t options (add -t 2 for 2 core)
https://docs.blender.org/manual/en/latest/advanced/command_line/render.html

It’s hard to render just the frame where it freezes as it’s completely random.

Cpu usage at 100% though occurred only the exact moment the render froze. And even waiting for a good five minutes didn’t change a thing, so i had to force closing the application.

What i don’t get is why it’s affecting the old animations as well, as they were rendering completely fine before.

About the prayer…i totally agree :cry:

Is it good to limit the cpu cores for the render? Sorry i’m quite ignorant above this matter :see_no_evil:

Did you try reseating everything?

There used to be a windows option in blender, toggle system console, which opened a dos prompt and gave errors in real time, open that and also check error logs.

Did you recently move the machine (different power outlet?) anything different?

Nope, i used Blender render even the morning before this thing happened (though i hadn’t render any animation within the past 10 days at least)

And what do you mean by “reseating”? Sorry am really noobish.
Also if there’s a way to post here an error log so that you expert guys could interpretate it and maybe find the reason of this nonsense, would you mind explaining me how to do that please?

Reseating is when you take a card out and rock it back into like a pci slot, this is for towers only not laptops, is this a laptop?

You can just copy and paste crash and error logs, not sure where they are on windiws maybe c:/tmp

yeh, it’s a tower pc. I’ll try to find the log and post it here. Thanks for your patience

EDIT: the log file is too long to be copy and pasted here. is there a way to attach files?

paste the most recent page or two, otherwise I think you need to use like dropbox

Ok Tim, i’ll do it tomorrow as pc is already turned off and am off to sleep as well. Thanks for your kindness :pray:t3:

1 Like

I recently updated my hardware from Macbook Air to a desktop with Windows 10, and I am having the exact same problem described here, happened 3 times in the last 2 days. It never happened on my tiny Mac over half a year of use, even thought due to its small powers some animation sequences took 4-5 days of constant rendering.

Can you list your system/gpu specs and blender version and explain the issue some more.

Hey Tim, sorry for the delayed reply, i feel quite at a loss as i checked the Blender main folder and there are apparently three different types of files that produce logs:

blender_debug_gpu.cmd
blender_debug_gpu_glitchworkaround.cmd
blender_debug_log.cmd

I tried all of them but sometimes the log is just a few bunch of lines, corresponding to the frames that got actually rendered, some other times is soo long and full of pages but apparently without any sign of errors.
Most of the times Blender render now freezes and the only way out is to force close it by terminating the program, other times though it simply crash out without even any error window, it just goes back to windows desktop.

I’m even ready to do a system format if needed, as desperate and silly it might sound. Or if there is a way to proper clean uninstall the software from the system (just uninstalling won’t remove the registry files) i’d try that first. :frowning: