I need help please: Blender suddenly won't complete the rendering of an animation

Ok i’ll do as you suggest though i’ve got the feeling that’s something i already tried two days ago, when i noticed the issue the first time though it didn’t work. But i’ll try again and see what happens. We’ll leep you updated. Thanks again for your generosity and availability mate. :pray:t3::blue_heart:

if that doesn’t work, i guess you should post the blend for someone else to look at. if you can save it as another name, pack it, save it and then post a link to dropbox or similar.


Motherboard: AMD Ryzen A520 Aorus Elite
Processor: AMD Ryzen 7 3700X
RAM: Corsair Vengeance RGB Pro 16+16 GB
Graphics Card: Nvidia GeForce GTX 1650 4GB (as I have learned it’s not supported and used in Cycles OpenCL rendering, haven’t figured out yet whether it can be upgraded for that. At the moment all my Cycles rendering is through CPU)
SSD drive: Corsair MP600 Gen4 PCle 1TB (free space 400GB)
Windows 10 Home
Blender 2.92

Issue is practically the same as described by @Da_Drood: while rendering animation Blender randomly freezes and cannot be recovered other than through terminating process in Task Manager and then reopening.

Over last week I rendered a few sequences of 250 frames. The only pattern I noticed was that those with smaller render time per frame (in my case, under 7 mins) completed successfully, without freezing, while those with around 10 mins per frame keep freezing after a few frames. Sometimes it happens when just starting the render (no frames rendered) and sometimes after successfully rendering some frames. When it freezes in the middle of render, it has the respective frame completed (showing 100% in the render bar) and saved in the render folder, but does not proceed to the next frame. All the while the CPU and RAM in the task manager is showing same high engagement as when rendering. I don’t run other software while rendering. Couple of screenshots attached.

WhatsApp Image 2021-06-05 at 09.05.42 (1)

Can you expand the memory tab to show the units. the question is is that 23,000kb (23MB) or 23,000 MB which would be 23 GB, if it’s 23 GB that would explain why the system is hosed, and looks like either a memory leak or misallocated memory. Can you widen that memory column to show the unit?

OpenCL is only for AMD cards. For Nvidia cards you use the far superior CUDA (or OPTIX for RTX cards).

1 Like

Sure enough, it froze again after a few frames, and yes, this time it is 15,000 MB, or 15 GB.

Can you share your packed file or us it top secret?

@Photox not a top secret :slight_smile: I doubt whether it’s the file because the above situation has happened already with 3 different files, but anyway I share here the smallest one of them that just froze today:

@init_pixel Thanks a lot for the hint, I am actually having some trouble with my graphics card, but since it’s probably off the topic of this thread, I started a new one here:

Don’t know if this could help, but i might have found a way out of this hell (i really hope so).
In my case i just had to shrink the whole landscape and all the objects to a much smaller size, then i reset the scale and recreated the various particle systems (it was quicker than the first time since i had weight paints already).
When i did the first test it rendered 96/96 frames without any issue and also pretty quickly, never going loud with the fans.
I’m still a bit confused about it though as the poly count remained basically the same as i didn’t apply any decimation.
It came in my mind i saw once a video on youtube where the guy was mentioning Blender not liking neither huge nor micro polygons when animating, and i guess i understand now why since my animated scene was on top of a 200 sqm landscape :sweat_smile::see_no_evil:
This experience kinda left me a scar and i still feel anxiety and paranoia when Blender is rendering. I hope it’s going away soon, not a nice feeling :sweat_smile::v:t3:

1 Like

@Da_Drood , well it’ something!

@DhameswaraArt , I baked the systems and rendered a bunch of frames in the middle, no problem.

I’m not quite sure what to say, issues and crashes that occur only sometimes are the trickiest to troubleshoot. Try and find the crash logs, I don’t use Windows and I don’t know where they are, but they are pretty easy to find, on linux they are in /tmp

hmmm, Both issue involve multiple particle systems, have either of you tried baking all the caches to disk?


I personally didn’t bake anything

I wonder if you hit a memory overflow as more particles spawned while rendering. Calculating both the physics simulation and the rendering simultaneously may have triggered an rare unknown bug since baking the simulation is part of the usual workflow.:thinking:

Glad that it is working for you whatever the cause was.

1 Like

My particles were baked. Anyway, will look for crash logs and try to figure it out. Yeah, it’s tricky that sometimes things work out completely normally, and sometimes not. But in any case, as always thanks guys for the amazing Blender community support!

In my gut i feel like there is some kind of bug involving particles and windows and a memory leak, but without being able to reproduce it myself im not sure what to say. Do either of you have a Linux (or mac) machine you can try it on?

Unfortunately i don’t have a linux machine to try on. But i agree with your feeling as it’s mine as well. Sometimes some things (beside this most recent one) happened in the previous months were unexplainable, and for example the same procedure was working in a file but not in another, so by appending everything i was able to sort the issue out, which leads me to think that files might get corrupted somehow.
But i’m really still just a noob with Blender, so i’m not sure of my conclusions neither. :man_shrugging:t3:

@Photox I have only used Windows with Blender for 3 weeks now. Before that I was working on MacBook Air, with Intel Core i5, 8 GB Ram, Intel UHD Graphics 1536 MB. In January-February this year I did a short animation project that involved a lot of fire and particles. I did not know about baking, so nothing was baked. Some sequences took 4-5 days of constant rendering at 40 mins to 1 hr per frame. On top of that, during daytime I was always doing something else on my MacBook while rendering. But it never, ever froze or crashed… Slow, but steady :sweat_smile:

I just wanted to thank whoever spent some of their own time to try to help with the issue. I really appreciated it! :pray: :blue_heart:

I have a new weird issue within the same scene now though… :rofl: (no rendering freezes at least! :sweat_smile:)
You folks think i can keep this post open to explain about it or shall i create a new topic?

If it’s a different issue, start a new topic with an appropriate title.

I will! Thanks again