I need tips and help with smoothing

Hello, I have problem with smoothing. It might be a simple thing but it wont work for me. I have made a pile of wood with both edges and circular patterns (i will attach my file). I want to smooth just some edges and circular patterns but it wont let me do that. I have tried to use smooth shading options, smooth vertex and edgesplit+subdivision surface. The last one worked on other things I have done but it doesnt now. When i use edge split i have the option to change the degrees for something and I do usually change it to 89 becase 90 and above cause trouble. Do you have smoothing tips or can you help me plz? I have honestly searched alot but it’s difficult to find something usefull. I have looked at wiki and several other sources for help but I still can’t manage.

Attachments

Hög av ved_005.blend (397 KB)

Select the edges you want sharp and mark them as sharp (Ctrl+E / Mark Sharp)
With the edge split modifier disable Edge Angle and enable Sharp Edges.
Apply smooth shading. All edges will be smooth apart from those which you have specifically marked as sharp

You can also select faces you want to be shaded flat and apply the shading options


Note: If you want to use subsrf modifier best replace those ngons (faces with > four sides) with quads

Good tip, but something is strange. I cant use the smooth shading on edges and verticies at all. Nothing happen when i use these commands, absolutely nothing. It just pops up a little option field with the alternatives “clear” and “verticies” at the bottom of the toolbar. Might it be something wrong with my settings or is it normally this way?

Works perfectly for me with your blend file. No popups. Show us exactly what you see preferably with a screencast so we see exactly what you are doing

Using the flat face smoothing


You can just apply smooth/flat shading to selected faces rather than to the whole object with the Ctrl+F shortcut

Yes, the shading of the faces work fine for me but thats not what i want… As you see on the picture there is still clear edges where i don’t want edges. The circular shapes is supposed to be smooth.