I need to compile a sequence plugin for windows.

I need to compile a sequence plugin for my windows blender setup.

I went to the blender plugin repository and downloaded Lcc like they recommended. I wanted to see if I could compile a working plugin DLL, so I used the source from an existing plugin I know works.

I followed the steps and made a dll that was 12kb and did not work. The pre-made dll was 238kb.

Is there another way to compile or did I neglect something in the procedure? I thought I followed it fairly well.


I tried as well but got an error from DOS

/me proposes a Vague Description of Easily Fixed Problem Contest and nominates the above two posts as the first entries.

I said exactly what I did. I followed the instructions from the Blender Plugin Repository for creating a windows .dll with lcc. If you go there you can read exactly what I did, I’m not going to relist the instructions I found there. Here is a link to the directions I followed:


When I compiled I got a warning about prototype missing for printf but no errors. I looked up the warning in the lcc docs and it says the warning shouldn’t affect the output.

Thats it. Specific enough?

I’ve never done this before, so how can I be more specific if I don’t have a clue about what I am trying to do. It would be alot easier if someone who know how to do this would do it. The plugin is the recently released Lightsaber 1.0 sequence plugin.

Tell us more about the “did not work” part. That’s the interesting bit. You were doing quite well up to that point. Did it crash? Fail to load? Do nothing? Something other than what you expected?

If it’s any consolation, you are running a distant second behind Mr “got an error from DOS”.

okay, let me try to explain it here…

when i try to compile, i get a similar “missing prototype” warning but for the exp() function. Whatever. So i go ahead and link it, and the result is ~25kb. That’s about ten times smaller than the plugins on the repository. When I try to load it into blender, I get an “error in plugin” message.

that clear enough? :smiley: :wink:

I get the same as Qwe when I try to compile his lightsaber plugin. The one I tried before was the old_movie plugin just to see if I could make a blender plugin dll. I guess not at the moment.

I’m having marginal success using dev-c++(which uses mingw(which is the win32 port of gcc)). The plugin will load into the sequencer, but I think there must be something wrong with my code because I’m getting really weird results. Be prepared for a complete rewrite, folks, it could happen.

you windoze users better be dang glad I’m spending this much time on this :smiley: :wink:

I know I will be dang glad if you get it to work well. Have you tried compiling existing sequence plugins and see if they work properly? This would tell if it is your source code or the process of making the dll that is causing the weird results.

What kind of weird results?

these kind of weird results:


the glow plugin works fine when I compile it the same way, so i don’t think that the compilation is bad.