I need to make realistic looking Panels. Could someone please help out here?

When it comes to texturing, the enthusiasm I hold for my models falter significantly, and prompt me to usually stop or abandon my ideas after a couple unsuccessful tries. This time though, I really want to make it work. I want to have my project coming out looking as well as it does modeled with textures.

So if anyone can help me, I’d be grateful.

Firstly, let me show you the model.

It’s a model of the EarthGov Gunship from Dead Space 2, it can be seen chasing Issac Clarke around in various chapters of the game. You also may have seen my post in the Works in Progress section as well.

Here is an image of the gunship:

Now that nice and all, but I would like to have it textures before going onto using it for something like an animation.

Alright, here’s what I need help with.

The Gunship is mostly composed of paneling which I need a scratched white surface. With darker spots around the edges and it needs to look slightly worn.

I have no idea how to do this, so far I’ve been UV unwrapping it onto a texture I grabbed off the net that looked mostly what I want it to look like.

This is what I get:

To get a better idea about where this fits onto the spacecraft, here’s another image


It looks nothing like I want it too. It has no ‘depth’, its got this strange lighting effect that I couldn’t fix by changing the lighting settings around. And it just doesn’t seem to ‘fit’ into the rest of the spacecraft’s look. I don’t know how to fix this. I tried looking into some tutorials, but after watching a 40 minute one which never seemed to get anywhere at all, and hence made it confusing to follow. I gave up. If I could have some step by step instructions or some kind person to show me how to make these panels fit in I would be very grateful.

I’ve tried changing the lighting around, but I’m no genius with that either, and the changes I did make didn’t seem to make much of a difference in the effects I was getting with the ship, so I was stumped there too.

I also tried applying the texture to different plates, but not to much avail. I am horrible at doing anything with textures, but I really want to make this work. I will attach the files for the model here if anyone wants to take a look at it and tell me if I’ve got anything wrong with the setup to begin with.

The file download link is here with attached textures ect:
http://www.mediafire.com/download.php?n1cef7jl4w9w5nh

If you take a look at this and can help me out, thanks a bunch!

You forgot to “Remove Doubles” before unwrapping the UV map.



unwrap again and it should be smooth this time.

Nice model by the way! I loved Dead Space 2!

Thanks man! It looks nicer now. More like I wanted it to look!
I hate to seem rude, but are specular maps what add shadows to the piece? How might I make it have shadows on the corners? I just want to make it look really realistic.

Specular maps control the “Shinyness”. If you had a spec map with a white center, and dark edges, then the edges would be dull/flat.

Typically to get a good shadow effect you’d combine both Color (darken the edges) and a Spec map.

Thanks much for your answer. However, while trying to texture another close panel, I encountered a problem I can’t seem to fix. It can be seen here in this image


You can see on the panel next to the cockpit window that there is some sort of inconsistency with the texture. I am not sure why that is happening. I’ve tried going into the mesh and looking for loose points, but I’ve tried merging many points around where the issue is taking place and it doesn’t seem to solve the problem. I’ve also tried removing doubles if that helps at all. It looks like there is some sort of disconnection but I can’t seem to place what is wrong. I’ve already tried ‘patching’ it but to no avail. Can you take a look? Could you also recommend any way to make the panels look a little better?

Ok, here are some tips to help clean up your mesh so the UV’s will display better:

1: While in object mode, press CTRL-A and click Apply Scale. This will make sure the UV’s don’t get squashed.


2: Remove Doubles. (See previous post)

3: Make sure the normals are flipped the right way.

  • Turn on Backface Culling (this isn’t ~entirely~ needed, but it does help display which faces are pointing the wrong way)
  • Under Mesh Display, under Normal click on the Face Icon, and turn up the Size till you can see the blue normal lines sticking out.
  • In the toolbar, click Recalculate. Generally recalculate is pretty smart about automagically making the normals point the right way. If not, you can go in and manually flip them by hand by using Flip Direction.


4: Make sure there’s no bad topology, errant vertices etc. An easy way to do this is: First, go into vertex mode, and deselect your mesh. Go to Select down in the bottom right corner, and select Non Manifold. (A manifold vertex is one that has faces all around it, a closed object like a sphere or cube that you could hold water in would be “Manifold”. A non-manifold vertex is either on an edge (like the edge of a plane), or not joined properly (like a hole in a sphere).)

We can see there are quite a few vertices that aren’t on an edge that show up as non-manifold. Fix all these and then the mesh should be clean.


Thanks much for the reply and sorry mine is a bit late, but once I select these non manifold vertices, how am I to fix them?

Turn on “Enable Snapping” and “Vertex”.

Then select the bad vertex, grab (G), and snap it to the nearest proper one.

Or select two vertices, press W to bring up the specials menu, and Merge.

Then Remove Doubles. Check to make sure it’s clean by checking for non-manifold vertices again.