I see some kind of xray, how to get rid of it?

Hello,

I was working on an object and wanted to open a previous file of the same object (everytime I change something I save it to a new file). I wanted to have both open, so 2 blender windows. When I opened the previous file my object turned into some kind of xray, I had this a couple of times before but when I closed both of them en reopened 1 of them again everything was fine and I could see my mesh.
Now everything stays in xray, I have like 25 files and even the first one shows xray.
This way I can’t edit anyting, I’m able to go into edit mode but I can’t do anything there. In object mode the only thing I can do is move, scale and rotate.

What I’ve tried already:
Turning on/off wireframe for display
At the object tab turning on/off xray (both was already off)
Link/append the meshes into a new file
Opening with a previous version of blender.
Searched all over the internet, but couldn’t find a similar problem

All didn’t work. The version I use is 2.58a

I really want to get rid of this xray view and want to see my mesh again.
I hope someone can give me the solution and that I don’t need to start over.

At the moment I can’t think of any additional information, besides that the textures are still in the file (in my uv window and in the textures tab, connected to my materials)

Thanks in advance

Blendfile added

Wedge25.blend (3.24 MB)

What x-ray effect ?

Your screenshot shows you’re in wireframe view ? (dropdown list next to Object/Edit mode selection)

Hello Richard, well that’s the thing… It’s some sort of wireframe (thought they called it xray as well) but it’s not. As I said I even turned it on/off to see if that was the problem. But I see no difference between wireframe, solid and textured. It all looks like the picture. Only bounding box would be different ofcourse.
Any ideas?

I don’t see anything wrong with this file when I open it. Here’s a screenshot:
You could try loading factory settings. A thought. And btw, nice pump!


Press ‘z’ and see if that helps.

1 Like

Ajm, the Z is the same as wireframe, which wasn’t on. But thanks for thinking.
Blenderallday, thank you for opening my file, I have fixed my problem right now, I just noticed in the upper part of the screen that my mesh didn’t had any faces. When thinking of this it came to my mind that when I enable vertices that I could edit my mesh now, which I ofcourse couldn’t do because I had faces enabled which are not clickable if they aren’t there. So I filled all the faces. Problem solved.

But there are 2 things left I don’t understand, first is why are you, Blenderallday, able to see my mesh with faces while I’m opening the same file and in my file they are gone. Second, how (or why) did I loose all my faces? The only thing I did was opening 2 different files. Especially on the second question I would like to know the answer.

Blenderallday, I didn’t try to load factory settings, because I already fixed it before reading the forum. But I will keep that in mind if it happens a next time, thank you. Also a thank you for your compliment, this is my first model I made, so very nice to hear!

This is beginning to sound like some sort of issue with your version of blender. There are faces on that blend you posted, just look. What version you running?

I guess the problem is indeed the versions (as from the 1st post he’s using Blender 2.58), this blend was very likely saved in a version of Blender superior to 2.62

Because every blend files saved in Blender 2.63 --without-- enabling “Legacy Mesh Format” in the save settings will have all the faces being removed (it’s then not wireframe/xray, it’s all the faces that have been deleted leaving only edges and vertices behind) if loaded into a Blender 2.62 or inferior.

The fix is then simple fortunately, just load your blend in the current version of Blender ( 2.67 ) and save it while enabling Legacy Mesh Format, you should then be able to open it in your version 2.58 without all the faces being deleted.

http://i.imgur.com/Rozgqzj.jpg

Sounds right.

Thank you for explaining what have caused this.
The version I’m running is, 2.58a. At least, that is what Blender is saying. But I just noticed by coincedence that the remover for programs in Windows is saying that I have version 2.64a. So no idea which version I actually have, but I will download the newest version and stick with that one.

Sorry for such a late response, but still wanted to say a thank you for the help.

Thanks that helps