I seem to have more than one material but can't find them..?

I’m new to Blender so I apologize if this is a stupid question, but it’s driving me crazy and the solutions people suggest on IRC have no effect

![http://upload.dfyb.net/uploaded/Screen shot 2011-05-25 at 12.40.27.png](http://upload.dfyb.net/uploaded/Screen shot 2011-05-25 at 12.40.27.png)

So I created this 2D mesh mostly by extruding individual vertices and using ‘fill’ to make the faces – the faces created this way seem to be on a second material and I can’t find a way to consolidate them into one. I know the UV map is correct because in-game, I can set the object to use two materials and the second material fills in these faces (this doubles the drawcalls though, so it’s not a good fix).

In the material section, there was initially no materials listed – I tried creating a new one, selecting all the verts (also tried faces) and clicked assign but nothing happens. The faces aren’t facing the wrong way and I’ve tried recalculating normals.

I feel like something is hidden from me or is locked and I’m just not seeing it. I’ve tried IRC but nothing has worked…

http://upload.dfyb.net/uploaded/Screen%20shot%202011-05-25%20at%2011.36.36.png
Any help is GREATLY appreciated. Looks great in-game but I can’t keep the additional needless draw calls for performance reasons.

Seems too me that one poly simply has another image applied in the uv image editor, try to unlink the uv from the image and then link it back again, should fix the texture view problem.

That did it. Thanks!