Icarus Import Script error! help!

i’ve wanted to do camera tracking for a long time in blender so i finally download icarus and the script to import it into blender, but when i import some tracking information from a *.txt file and try to create curves its says

“Unexpected start of file, nothing done” :< :frowning: this is super dumb, can someone please explain why it isn’t working-

icarus 2.01
blender 2.34

Your Blender is probably too new. Use an older Blender, like 2.23 - 2.25.
Come to think of it, you might need an older version of Python as well.

It’s been about 18 months since they stopped ICARUS. I only ever got it to work once, but that’s all I needed to be happy. Camera Calibration and Tracking rocks.

Yeah, try using Blender 2.31. I cannot use the newest version of Mac OS X (10.3) because the python version is too recent. I’ve got to switch to OS 10.2 to get back to Python 2 (I think), and then use an out-of-date version of Blender. It’s the only way I’ve gotten it to work. :-?

–Colin

Well, that error is a message while the script is running, so it is not a python problem or OS problem, the script obviously works. However, I don’t know which version you use, there seem to be a few around now, that message just means it can’t interpret the file it is trying to read, there have been a few Icarus fileformat changes, older versions are different.
So, first, what version of the script are you using (at the top of the script)? (where did you get it from btw?)
And also, just in case, I got an email from someone some time ago who was actually trying to use the wrong fileformat, you need to export a ‘human-readable’ text file.
I had also updated it once more, so it should work in 2.34 now too, python & OS issues aside.

Hey eeshlo! I believe he downloaded your script from the thread: https://blenderartists.org/forum/viewtopic.php?t=30217&postdays=0&postorder=asc&start=0 I’ve hosted your script on my server (link is at the bottom of my post)… but it seems you’ve updated it, huh? Is it available online??

I’d like to thank you again, eeshlo, for the script, and your help with getting it to work. I am relying on it immensely for an upcoming film. :slight_smile:

–Colin

Very nice work Colin! I also really like how you managed to create the illusion of a really large space in that other animation in the wip forum.
Anyway, I only updated it for the person that mailed me, don’t know if it worked for him though, never heard anything back, other then that it wasn’t working (which was because he was trying to load the wrong file).
So it’s not available online, I’ll send you the updated script, but I only tested it on Linux with a cvs compiled version of Blender, I don’t know if it will work for everybody.

this is the start of the *.txt (human readable) file that i exported using icarus…

# 2D Feature tracks exported by ICARUS v2.07

“name”

<3d position>

<number of frames>

<frame number> <x pixel> <y pixel>

“1”
0 0 0
29
0 244 45
1 242.552 45.2647
2 241.229 45.7889
3 239.385 46.7805
4 238.699 47.6046
5 237.646 49.1805
6 234.527 52.1129 . . . . (and more)

if you can send me the updated script it would be great. i’m using windows xp though so i don’t know about compatibility.

i’m using blender 2.31a and python 2.1.3 and i’m still getting the same message that it has “Unexpected start of file, nothing done”

Funny… you are making the same mistake as the person I mentioned, you have the wrong fileformat. I’ll just repeat the same from my reply to his email:

It’s not surprising it doesn’t work, you are using the
wrong output fileformat, the 2d option. You need to
“Export 3d Motion” (File menu), then select “Human
Readable(*.txt)” from the “File type” menu. The script
only accepts output in ‘human readable’ format, no
other.

To effstops:
I think in the mean time the python api has changed a bit again, so I’ll have to check to make sure it all works correctly, I’ll send you the file tomorrow.

as normally i feel quite dumb. it finally works even though i still have to use blender 2.31a but can’t i just open the camero IPO in the newer version? anyway thnx a ton guys

Garrett

I sent the updated script to effstops. The updated script can now do everything, no need to set any parameters yourself anymore.

can’t i just open the camero IPO in the newer version?

Not sure what you mean exactly, if you mean if the script now can create a Camera lens curve instead of doing it yourself, then yes, as I said above, the script can do everything it needs to do now.

Where can I get the updated script?

Well, I assume effstops will make it available for download like before, that is why I sent it to him. If not, I don’t have any site other than my old site which I don’t use anymore, so if you want it, send me a PM with your email address and I’ll send you the script.

eeshlo, thanks for your comments on my animations! And thanks for the updated script. Unfortunately, I haven’t gotten it to work. I tried with Blender 2.34 in Mac OS 10.3, and 10.2 (where I have had to use the previous script). I’m sure it’s a problem on my end-- prolly setting up my python path? I dunno, I’ll figure it out.

ANYWAY. It is now on my website for anyone who wants to try it out:

http://www.peerlessproductions.com/Icarus_Import234.zip

–Colin

Well, if the previous script works without problems I don’t think the python path has anything to do with it. I did get some warnings in the console though in the official 2.34 (about expecting an integer instead of a float), but I didn’t do anything about it. It seemed to run ok, and no warnings at all in newly compiled versions, so I just left it as is.
Anyway, I now this is not standard for the Mac, but have you tried running from a console, and if so, any warning/errors (if any at all)?

Actually, I just tried inserting the lines

import sys
sys.path.extend(['', '/usr/lib/python2.2', '/usr/lib/python2.2/plat-darwin', '/usr/lib/python2.2/lib-tk', '/usr/lib/python2.2/lib-dynload', '/usr/lib/python2.2/site-packages'])

at the beginning of the script. It ran-- in OS 10.2. So I’ve just got to work on getting python in OS 10.3 running right. :slight_smile: Right?

My error in 10.3 is: “ImportError: No module named math”

I’ll try to figure it out. Until then, I’ll be satisfied with what I have. :smiley:

–Colin

I think the problem then is that Blender has now upgraded to python 2.3, it doesn’t use 2.2 anymore. By extending the system path that way, it will load the 2.2 math module instead, and you probably get a ‘version mismatch for module math’ warning (in the console).