ICARUS on Windows

I’m having trouble getting ICARUS to work again on my Windows Me system. I tried one of the ICARUS tutorials about a year ago and it worked fine. Now when I try to open the sample movies I get the following message:

Unsupported movie format.

In fact, I can’t get any movie format to work with ICARUS. Codec problem? It used to work…

Second. I appear to have a configuration problem with the ICARUS path. When I try to open one of the projects, I get the message:

Failed to load C:\Program Files\Icarus/movies/building2.avi

Is this a path problem (forward vs. backward slash) or is this the same problem as above?

Based on this forum there are people who’ve gotten ICARUS to work on Windows. Any help with this would be great.


Can’t help you with the other issue since I’ve never used ICARUS, but the use of forward and/or backward slashes on the Windows platform is certainly not an issue since both are recognized by Windows.

Thanks richardve. That put’s my mind to rest about the paths. So now I’m guessing that it’s just a codec issue. Can anyone confirm this for me? What codec and where is it available? I feel like I’m so close to getting it to work. Any clues from those who know are appreciated.


Edit: I’m getting closer. At first I couldn’t play the sample ICARUS movies on my computer at all. Tried the Canopus DV codec - no luck. Tried the Panasonic VFW DV codec - now I can play the movies in VirtualDub but still not working in ICARUS. …nudge me in the right direction…

Edit2: Tried various flavors and versions of Directx - No luck. The ICARUS documentation claims that it supports several video format files. I can’t get any video to load. Also says you need Directx 8.1 which I have.

got your privmsg… hmm… I remember I had some problems also… I’m using xp tho… I think it’s a codec issue… I remember the main concept dv codec worked… it has a trial version that has a watermark…

but like what codec’s do you want to use?

I edit my videos with mjpeg because that’s the format they come in through my capture card… but I suppose icarus should work with anything you can open normally in windows if it uses directx…

don’t know about the path problem… but it might be that icarus doesn’t like paths with spaces like your “\program files”…

dunno if any of this helps…

Icarus should work with Pansonic’s DV-Codec. But in fact it doesn’t - at least not on my computer.
What does work is quicktime. and it looks pretty much it is the only codec that works…

As far as I can remember my icarus version neither could open the building-file. But I guess it was this part of the software that gives you an introduction. I never used this, but the “real” calibration module works, though it sometimes crashes…


Thanks for the replies guys,

Well, I give up for now. It’s not a path issue or a space in ‘Program Files’ issue either. I’ve tried the Canopus, Panasonic and Main Concept DV codecs with no luck. Quicktime has not solved the problem either. I removed all codecs from my machine and reinstalled them individually and together. I continued to experiment with DirectX including downloading the 8.1SDK and trying the debug files.

All with no luck. :<

I’ll try again when I buy my next computer.


This is what I experienced at my own expense. I succeeded to make it function again after my kids upgraded to DirectX9 for a game by using a “DirectX9 uninstaller” from “superfoxs”. Use keywords between quotes in google to find it.
Good luck.

It’s no longer available for download at official site. Thanks.

my e-mail address is [email protected]