Icarus Problem

I’m getting an error when I try to load an Icarus file. Mac OSX 10.3.9, using this script, ICARUS_import234_2.py and Blender 2.4.

This is what I get from the console:

/Applications/blender-2.40 Folder/blender-2.40-OSX-10.3±py2.3-po Folder/Blender.app/Contents/MacOS/blender:543: DeprecationWarning: integer argument expected, got float

Yep, getting the same problem here. The “depcrecation warning” you’re seeing is in Blender itself. The actual error being thrown up is:

“AttributeError: ‘IpoCurve’ object has no attribute ‘points’” from routine “MakeIpoCurves.”

I’m using Python 2.4 and it seems that you’re using 2.3, so that kind of rules out a Python problem. Could be something to do with the animation system recode. JMS or anyone who’s familiar with this script, any chance of getting an update?

Many thanks for any help!

Going off topic but do you guys have a link where I could download icarus?

I had it on my comp then a virus infected it causing me to do a hard drive wipe.


I got the error in Blender v2.4, but not in v2.37a

Even with the error, ICARUS seemed to work anyhow, for me. But to be safe, I insalled v2.37a just to do ICARUS projects.

Get Version 2.09 HERE... http://www.salatar.com/icarus.exe

Get it WHILE it lasts. So hurry!

You can’t do it thru the filebrowser, you have to open the Text Editor, click on the menu and choose Open New.


I got the same error, I solved it by having a camera already there in Blender before importing the tracked scrypt.