Ice and Yafray

I’ve been working on some YafRay tests just to see what it can do over Blender’s internal renderer (which I’ve been using since the beginning).

I did I semi-abstract image of ice islands just to see how it would work.

I must say I am impressed with the quality of the images that YafRay puts out, and the speed at which it renders with Ray Tracing. (Since I’m running AMD, the processor isn’t as strong as Intel’s for rendering capabilities, so every bit of speed counts) :confused::confused:

Image was rendered, then glow was added in the compositor.

Hope you like,

Cool. Looks like it’d make a decent wallpaper on deviant art. Was the glow done with the sequence editor or with actual composite nodes?

Composite nodes. It was done by taking two render layers and feeding one of them into a saturation increaser, blurred, then added back into the other render layer.

The process was done as shown:


can i have a look at your lighting setup and settings? I think that it needs more caustics

If those two render-layer nodes are using the same image, you can string the image outputs to the hue/satutration and mix(add) nodes from one renderlayer node.

i really like this image. the specularity on the vines gives a nice scale.


The lighting setup is fairly simple. Three spot-lights projected onto the ice at different angles:

Mind you that the original render was in the Blender Internal with Z-Transp rather than Ray-Transp, and it was for an animation, rather than a single image. So I tried to keep the lights down to save render time.

Having said that, I used two render layers originally because I had different contrast settings and blur for each before I use the “Add” feature. So in the end, I didn’t need it, and I just plugged the render laying into the glow group.

Here’s a link to the Blender Internal Render Vid:

It was done with the two back ice platforms as a seperate render layer and blurred. I didn’t really like the way that looked so I’m glad that I used YafRay for this one! :eek:


I would use photon lamps to get nice caustics.

OK, I tried rendering this time with photon lamps.

Here are the results:

With Photons

Without Photons

Final Product w/ Photons and Glow

IMHO, it makes the ice lighter and clearer. It’s a nice effect but it does certainly add to the render time! :eek:


Very Nice!

Just hoping to clarify, you did this with the old YafRay, not the newer Yaf(a)Ray, right?

I haven’t really looked at Yaf(a)Ray, but I thought I remembered reading somewhere it was better for caustics, or something. Maybe it was just faster…I don’t know.

the very first version seems the best for me, the photon tests are “too clean”

I’m using YafRay 0.0.9 I think. I’m not sure what Yaf(a)Ray offers, but I have heard of it.

Anyone care to shed some light on that subject?



hi, first, amazing image!

it looks so nice

but yeah
i have 2 questions:

  • that glow node, is it a patch?? i tried to find it in 2.44 but couldnt, or was it to illustrate the 3 node within?

*how did u get yafray to work with nodes??? i tired to but nothing happened! i imagiend that the yafray image would simply render than put it into the render layer and it would go from there


again amazing image and i hope that you could answere me these 2 questions.

thanks you


  1. The “Glow Node” is actually a grouping of three nodes (you can do that you know, comes in very handy!). It consists of a Hue/Sat/Val node, Blur node, and Add node. I then grouped them and saved them in the default settings.

  2. YafRay does not immediately work with nodes, as far as I can tell. Layering, I believe, is almost impossible.

To get the YafRay layer to work, all I have to do is simply update the node sequence by changing a value or whatnot, whatever causes it to update. Yafray should then work with nodes. I also assume you need “Do Composite” activated in the render buttons.

Here’s my setup (two pics, because I have two screens):

Don’t worry about the values that go off screen, they are for Depth of Field. The HSV, Blur, and Add I ungrouped for easy viewing.

That’s just a random icecube by the way! :smiley:

Unless someone can prove me wrong (and I hope they do), YafRay doesn’t share a totally tight connection with Blender’s compositor like the internal does.If I do layers in YafRay I save them as individual images, it seems to be the only way.

Edit: This, by the way, is the final version of that image after some more compositing and material changes:


thats a beautiful image btw

u said u have 2 screens, i do too! but when i restart blender, it only opens onto one screen and then i have to drag and resize all. is this the same for u? or is there a trick?

To get the YafRay layer to work, all I have to do is simply update the node sequence by changing a value or whatnot, whatever causes it to update. Yafray should then work with nodes. I also assume you need “Do Composite” activated in the render buttons.

by simply updating it should work?? rly? i must try this, so yeah

thank you very much
again beutiful render very nice

also, i really like ur theme. its looks very nice

jsut a simple idea, but could u make that theme avaiable perhaps? i not thats alright i understand that u probably spent some time to tweak it like this, i was jsut thinking:)


Yes, I have two screens, and yes Blender starts on one screen each time. I simply set it up so that the windows are in the right place when I drag it across both (in DualView mode).

The theme I use (and many more) are available here:

They come in Python Scripts I believe, so you’ll have to load them with the text editor and execute them, then save the default settings. I thought the original theme was two bright and the alternative theme was too grey, so I picked up that one, and it works great.


i yse abn ati card
and in the catalyst control center for the 2 monitors
“cloen” , “extend”,“stretch horizontally”.

by accident i presses the strestch horizontally, and now i have a desktop thats the main desktop, thats 2560 x1024. stretches both screens, no 2nd monitor is enabled, and blender opens directly to the 2 monitors. idk what graphic card u have, but if its an ati try it
if its nvidia, im sure they have something similar

I have an nVidia card. However, if I run in extend mode I can’t run my games. So I keep it in dualview, and it works fine.