ik problem on blender 2.5 beta


does anyone know why when I ty to add an ik constraint I always receive a message ‘ik constraint can only be added to bones’?
I have bones selected, but it doens’t seem to work…
is this a bug?

I’m not sure, I’ve just tried it and no matter what I do I cannot get the IK constraint, or the IK spline constraint to work.

Tried selecting bone in pose mode, in edit mode, in object mode, try selecting single bone, multiple bones. Nothing seems to work.

I just noticed that in the console window it say 9 90 9 90 9 90.
Any idea?

if you go to pose mode and click shift control c and select ik the constraint is added but it doesn’t appear in the constraint property window…

It could be a bug, I’ve rigged in versions prior to 2.53 and it all worked fine. I would have thought some one would have encountered it by now. Maybe search the bug tracker for rigging/ animation issues, if it’s not listed it’s worth posting a bug report, after all you are getting something out of the console window, which I don’t think should be happening.

I closed and re-opened blender and it works… weird…