IK Solver - I try, and I try, and I try... :(

I know little about IK solvers. Let’s take something simple. I maded 3 bones, and I named a) Forearm Bone b) Arm Bone and c) Palm Bone. I selected the join between the Arm Bone and the Palm Bone and aded a new bone (with “extrude bone segments”). I called IK Solver Bone.

Now I don’t know how to work with contstrains so good. I selected the IK Solver Bone and picked the “IK Solver” constrain type from the Constrains panel. For BO I choosed the Palm Bone. I moved the IK Bone but… nothing. The bone is not even linked with the whole armature.

I need to know some steps…


some more steps here:


I found something nice:


I can try it and tell where I fail.

When I was following armature Blender 2.3x tutorials using 2.40a, I know I had to manually parent, and click the “Con” buttons for all the bones to get the armature assembled correctly.

If you don’t have the IK constraint, and you go to pose mode do all your bones move correctly?

Basically you just got it back to front.

The Palm bone should be the IK_Solver and he extra bone should be the Target. The idea is that you move the “target” and the solver always tries to point at the target. So rename your “IK Solver Bone” to “IK Target” (remove any constraint) then select the Palm bone and add a constraint to it and put “IK Target Bone” for BO.

Also, before you go much further you should probably remember to name your bones Left and Right (or .L .R) so you don’t make work for yourself later.

The new version (2.4) has a few different options but OTO’s tutorial should help you out there.

Ok, now is working, but I have one small problem:

the target bone is… moving!

I mean the whole arm is moving to, but the target bone just fly on the screen, up and down.

Maybe I can lock him to the IK Solver bone or something… How?

Maybe I can lock him to the IK Solver bone or something… How?

Select the Target bone in edit mode and click “CO”(nnect) button top right and choose bone to connect it to in the menu left of that.


One step and… it’s over!

Where is the connect button? I’m in edit mode, target bone is selected. I must look in Object Panel? Editing Panel?

I’m using the 2.37 version…

2.37 doesn’t have it; it has an IK button and a menu to choose the parent. F9, Armature Bones tab with bone selected.


It’s doesn’t work! I can parent the target bone with every bone i want, but it still moving. How can I fix the bone?

Where can I find the 2.40 version, and VafRay is working with the 2.40 version?

When you say “it keeps moving” what do you mean?

If you parent the target bone to an arm bone it will move when the arm moves. But as Fligh said, you must select the target bone and make sure its IK button is NOT pressed. (Edit Mode: F9 > Armature Bones).

You don’t have to parent it to this chain of bones for it to work. Many characters parent the IK bones to a Root Bone which controls the whole rig. See if it works without making it a child of any bones.

If this doesn’t help, can you explain exactly what happens when you do certain things and what bones you have parented, targeted and solving? Can you post screen shots or a blend file?