Illustrator to Blender - Possible to import open paths?

I made the attached image by creating paths in Illustrator, expanding and importing as .svg. So when imported to Blender the .svg is not a bezier curve, but shapes the width of the stroke in Illustrator. The result looks good with the sweep function, but it’s complicated to unwrap.

I’m thinking easier to use a bezier curve, sweep and apply solidify modifier instead, but I can’t figure out how to import open paths from Illustrator. Blender always closes the path. Doing the same type of curves with the bezier tool in Blender is pretty tricky. Is it possible to import open paths from Illustrator?


I assume, you are talking about that orange, white and blue shapes inside the batery. Why not use a plane, add loopcuts for the white parts and extrude them. Then make your round shape with the spin tool. I’m on mobile right now else I’d provide some screens…

Thanks for the quick response!
Sorry, I meant the outside. Here’s what I made in Illustrator:


I’d like to import the open paths from Illustrator and and use the spin tool, but Blender closes the paths when importing .svg. similar to below:


Import it as areference image. add a plane and delete 3 vertices. Put tehe remaining one on any end and extrude out the shape. Then use that one to spin. maybe then use a narrow solidify modifier. Maybe not the smartest way but it will work :wink:

Gotcha. Thanks! Is there a way to have fine control over the corner radius similar to Illustrator? I know how to use the bezier tool and covert to free and vector type, but Illustrator seems to make it a lot easier to make 90 degree angles and then just pull the control to shape the curves.


Try to replicate with subsurf and crease. Or beveling edges. First spin a “edgy” rough shape. Should be easier the…

I’ll give it a shot. Thank you!

Let’ s See what you came up with. In about two hours I’ll be at home and can try s.th. else if doesn’t turn out good.

Apologies for the delay! I extruded the single vertex at 90 degree angles, added sub surf, hit spin and applied mean crease, but can’t figure out how to keep the edges from folding over…


OK, again I am not at my comp to try anything. But here’s a suggestion: Try to spin first. Then apply a subsurf with simple enabled. Select the edges that should be rounded and try to bevel them. Coul’d you provide a blendfile with only the basic shapes? I mean before you did the spinning? Then I’ll look into it when I’ll be at home…

Thanks for the suggestion! Here’s what I got:



One on left is sub surf Simple and right is Catmull-Clark. Both have auto-smoothing turned on at 65 degree angle. Getting stepping on the left object.


Left side are vertices created in blender. Middle is imported .svg and on the right I joined the shapes, selected all, limited dissolve and deleted the edges to get back to the paths I made in Illustrator. It’s a bit of a pain, but accomplishes what I set out to do in the first place. Bevel downside is can’t adjust after setting. Makes me want to figure out how to use mean crease. Blend file below! ↓
Test.blend (836 KB)

I just did a similar test but exported an SVG from Affinity Designer. It came in as open curves.



How are you exporting/importing?

(ignore the differences in shape, I edited the curves in Blender a but before taking screenshot.

Nice! I tried both “save as” and “export as” .svg from illustrator and kept everything at default values.

perhaps the import SVG add-on you are using?

I’m using this one


same here…

This thread solves it! Needed to change the export settings in Illustrator. Thank you for the help!

Glad you found it, all the other options looked a bit painful :slight_smile:

If you import a .svg image from Illustrator into Blender, and Blender “closes” some of the open .svg paths, a simple option is to go into the “Object Data” panel of the curve in Blender, and to uncheck the box called “U” in Active Spline > Cyclic.

1 Like

Do you have an idea how to solve this issue in 2.8? I have an open path that blender closes automatically =/

A few tips:

  • If you activate the Testing category in Blender Preferences ➔ Add-ons, there’s an alternative 2D vector importer supporting AI, PDF and SVG files (at least in 2.8, I don’t have 2.79 installed anymore). You could try that as well.

  • There’s a great free add-on called Bézier Curve CAD Tools, that offers great enhanced curve tools, including fillets. In some cases using that on a native Blender curve might be faster than trying to correct imported vector files.

Good luck.