I'm about to go nuts :)

When I import an obj I cant go into edit mode to work with it. Please someone let me know what I am not doing or doing wrong. I have tried to separate by group and actually all the import options but still its an object that I cant work with. It stays in object mode only so I cant assign materials or well anything with it. Thanks =)

i guess you did not import the object,
you did make an link to the object from another blend-file.
To understand it,
this is something like creating an new object in blender and
then instead of duplicating this object with
if you use Alt-D
you only create LINKED duplicates.
So if you edit one of these linked ones, you always edit all linked duplicates.
Same procedure goes to the imported object as an linked-imported object.
You can only edit this object in its original blend-file and if you fire up
the new blend-file with the linked-imported object, than this will have the edit-changes
of the original one. Thats why you might not be able to edit the linked-in-object.
You can only make changes to things, that are not linked-in from other blend-files.

And – maybe a usefull feature – if you have in multiple blend-files a linked-in-object from a base-blend-file. You can edit the object in this base-blend-file and if you open one of the other blend-files you automatical get the changes imported there(because those blend-files only use a linke-in-copy).

That sounds like what is happening alright but its not just that one object also, its any object I have tried to import. Is there an import setup maybe that I have set wrong? Thanks for the reply =)

Can you attach an example blend file which shows this problem. You can attach by using the ‘Go Advanced’ button below the message box or upload to a hosting site like http://www.pasteall.org/


Here is the blend file you ask for. Thank you for taking a look at it for me =)


my import problem.blend (238 KB)

Right mouse click on the object to select it, then you can switch to edit mode.


Oh My, I knew it had to be something so simple that I just wasn’t doing =) Thank you ever so much for your help =))