I'm still having trouble with game engine physics and object weirdness

Still working on my domino animation. I’ve broken things up into individual blend files so that I can work on each part separately, that when this problem occurs it doesn’t f*** up everything I’ve worked on. So I have my basic domino object, and I duplicate it to create multiple dominoes. What happens is that when I hit “escape” to end recording the movement as IPOs, every duplicate object magically moves back to being concurrent with the original object. Completely screws up what I’m trying to do. Should I be ending the recording in a different way? I’ve been thru a couple of tuts to see if there’s a different keystroke I should use, but they all say to use escape. Help! This is driving me bonkers!


By any chance does your “Basic domino” already have an IPO curve attached? If so, every copy will be referencing the exact same ipo curve. When objects share an ipo curve that designates location, they will all move to the same spot.

In the attached file, there are 2 cubes in the exact same spot. Move the one that is selected, then advance forward 1 frame…see what happens.

Best of Luck!


sharedIPO.blend (212 KB)


I’ve thought about that, and it’s certainly how things are behaving, but as far as I can tell there’s no IPO curve already existing when I run the game engine. And I see the individual objects moving while the GE is running, it’s just when I end the GE that they all snap back to the same location. I just went back into my blend file, opened an IPO Curve window, selected objects in sequence, and nothing shows up. I’ve attached the blend in question, if you can see something I’m missing please tell me.

And thanks!

Note - I have not run the game engine on this copy of the file. It’s my backup so that I don’t lose all my work when I do run it…

Eric S


Domino2009_fallingflower1bu.blend (623 KB)

Hi there.
I had a look at your file, and it is indeed shared IPO’s They all have an IPO named “Cube.001” attached to them. Delete the link to this from the IPO editor, then you should be ready to run the sim.
Take a look at the attatchement and you’ll see what I mean.

Edit I deleted about half of the objects to get the file within attachementsize. the scene is split into two groups where one has the old IPO and the other half a new correct one.


Domino2009_fallingflower1bu-note.blend (591 KB)

OK, I can see that in the outliner window. When I try to unlink it, though, it says “not yet”. And I still don’t see anything in the IPO window. I’ll keep trying and see if I can remove the IPO.

Thank you!


Update, I’ve figured out how to delete the curves! Hurray! Thank you!