Image as Texture Not Evenly Applied

I have a .PNG image that I applied as a texture on a plane (they have the same X- and Y- dimensions). This was applied through the Properties > Textures > Type > Image or Movie rather than through UV mapping.

I had tested this before, and it seemed to work perfect: the Plane basically looked like it was the .PNG.

However, now it’s all screwed up. As you can see in the picture below, the Plane is only using, like, a tiny portion of the .PNG in the render. Before, it was perfectly even: the corners of the .PNG were also the corners of the plane. This is clearly not the case anymore.

Can anybody tell me what I might be doing wrong? (Like I said, it was working fine before.)

You are not UV mapping your plane. Just go ahead and do that.

I don’t really know how to do UV mapping.

And, like I said before, applying it as a Texture worked perfect before, and it seems faster and more efficient than UV mapping, anyhow, so it’d be good for future lurkers to learn, as well.

(What I’m thinking might be the problem now is that, somehow, when the Object is scaled, the Texture didn’t scale with it. Just a theory. I’m having so many damn problems I can’t keep track of them all. Will report back if I figure it out on my own.)

I noticed on your other thread about textures not appearing and being white when i multitexture display mode, and that’s why it happens if you don’t do UV mapping.

A quick example for your Plane + Texture case :

  • you have your Plane that has correct X/Y dimension according to the picture you want mapped on it.
  • go into Edit Mode and split your screen in 2, on one side the 3D view and on the other side set it to UV/Image Editor
  • in the UV/Image Editor click on Image -> Open Image and load your specific texture
  • in the 3D View select your plane and press U
  • in the popup menu that appear, you select Project From View (Bounds)
  • notice what it does in the UV/Image editor, it unwrap the plane so it fit the full texture (and that’s why it is a good idea to have your plane being the same X/Y ratio as your textures, so there’s no distorded part.

And the texture appears in 3D view too, it’s not white anymore.

But in the Material texture , you’ll have to set the “Mapping” to UV instead of the default “Generated” to have your model using the UV mapping you just made when you want to render.

The equivalent to this in 2.49b is in the “Map Input” -> change “Orco” to “UV” after setting the texture.

Well…I’m still working on it. I really want to do it with the simple apply texture (if only so I can figure out what the hell happened!)

But I understand your stressing the importance of UV Mapping. I can see that it’s a crucial part of most 3D models, and I have to devote myself to learning it, sometime. But for now, I want to just get this damn thing done.

I don’t mean to beg, but this has turned into a bigger problem than I ever expected. (I firmly recall testing out my process in advance and having no trouble with it. Now, it’s not working at all.)

The issue is very simple: the Material is not rendering properly on the animated Cube. Please see the picture below for this bewildering problem. If anybody would like the .Blend, please let me know (it’s over 20 MB now).

the characters are very likely irrelevant to that problem, so upload just the cube that is rendering wrongly (+ the texture packed) in a blend, much smaller to download and easier to pinpoint the problem.

is the other cube uv mapped ?

I know that the characters are probably not a factor (although, at this point, I wouldn’t be surprised by anything).

I went and pared down everything except for the Objects whose animations effect the Cube in question but it was still 10 MB and I couldn’t get it to load here at BlenderArtists. So I uploaded it to MediaFire instead:

So, please take a look a the .Blend attached and let me know if you can see why the Object that the character is holding (the scroll) isn’t properly rending its Texture.

Thanks a lot.

The problem is still the same. You need to lean how to unwrap. A cube or a plane is not that hard. Here is a plane image mapped in a 16:9 ratio. Also, try out import images as planes AddOn it will automatically create a plane that matches the image size you want to use for a texture. You have to activate the AddOn under User Preferences.


26_uv_plane.blend (83.2 KB)

How does that explain why it’s working fine on one cube and glitching on another?

I’ve identified the problem as something to do with the Curve Modifier that I have on the cube. When I “Apply” the Curve Modifier (keeping its slightly-cuved shape but freeing it from morphing into the shape of the Curve), the Texture is suddenly visible again.

But I need to keep that Curve Modifier on it, and so this doesn’t fix the problem, but it’s helped diagnose it.

How does that explain why it’s working fine on one cube and glitching on another?
Because you did something wrong. Your acting like it is Blender’s fault, not even considering it could be user error.

Awesome idea. That’s why I posted the .Blend so that people could take a look at it and diagnose the problem, whatever caused it. Thank you.

If anybody could look at this and offer potential solutions, I’d be hugely grateful. I have absolutely no clue what to do, and I’ve tried everything I can think of. The only remaining option is to reanimate the entire thing, but (a) that would take many hours, and (b) I have zero confidence that that would work, since comparable attempts to fix it have all failed.

Help is desperately needed.

Textures that are not procedural (so not noise/voronoi/marble/etc…) needs UV maps to be correctly displayed, using the “Generated” setting instead of “UV” in the mapping section will make their correct display being more a matter of “you were just lucky it was showing at all”.

UV map them as i mentionned in the step by step explanation up there and set the Mapping to UV instead of Generated and the textures will display (you didn’t packed the “diploma-graphic-back.png” texture in your .blend, so i can’t check if i have done it correctly to do it for you)

Okay, I’m going to try learning and implementing this UV Mapping right now. Don’t know how long it will take. Will report back.

You can too upload that texture and maybe i could help better.

The texture is very, very simple: The “cube” is just supposed to be a piece of paper. So I have a .PNG that says “DIPLOMA” on one side, and then a generic back on the other. (The only complicating factor is that there is some dead alpha space in the .PNG, and I don’t know how that’s gonna hold up.

This is all they are:

You say you have a png for the front and one for the back, but what you uploaded is a single texture ?
textures dimension and ratios are important when UV mapping on them, if this is not the correct texture, and i uv map with this, you will not see the texture on your side being displayed as it should.