Image-based plane light eliminates mesh light

I have a simple scene with a lantern in it, the latern’s bulb is a mesh with an emission shader. I of course light it from other angles as well, like from the side where I use a plane with an emission shader whose color is dictated by an image texture (so an image based light).
My problem is, no matter how weak the image based light is, even if it’s so weak it’s unnoticable in the scene, the effects of the mesh light basically eliminate. But as soon as I turn off the image based light, the mesh light wakes up again. This does not happen with light lights (e.g. area, spot etc) but those don’t look the way I want them to look. Some proof:

though noisy, you see here that the lightPlane1.001 is active, but strength is 0.1. It’s a blue-ish image, unnoticable in the scene. But even still, the mesh light is like secondary reflection only. On the contrary, when I turn off the image based light:

You see that the mesh light immediately kicked in. They do not share the same material (though it wouldn’t explain this either).

I’m using Cycles and I’m wtf-ed. Could someone help me? I’m not using any fancy group settings, everything is on the same layer.

the node setups:

Unfortunately the glass material doesn’t matter, if I remove it the problem persists.

Please ALWAYS supply an example .blend file with any support question.
Screenshots of the materials’ node setups are all well and good, but what about the render settings? A .blend file would answer all of our questions in one go.

Anyway, make sure you don’t use aggressive clamping in the render settings, as that may very well explain the effect you see in your render.

Scene size is 110 MB, afaik I can’T upload it here so I try to replicate the issue in a clean scene. (Un?)fortunately the issue is gone when using a new scene so I assume the render settings are to blame (unplugged the materials for the objects). I go ahead and copy the render settings from a fresh open scene to check if it works.

Okay, was able to reproduce the issue. <img src=“” /> here is the scene file.

You didn’t pack your images so the scene isn’t much use. And of course it looks nothing like the original scene. Makre some screenshots clearly showing issue in the new simpler scene, pack the images and upload again. I have no idea what is “supposed” to happen, or not happen. I did notice you are clamping indirect at .2, which can cause issues, change it to 0 which turns it off (low values --but not 0 which is a special off value – are actually clamping much much stronger)

The original was 110 MB, of course the 1.3 MB one looks nothing like that :smiley: (I said I can’t upload and reproduce the problem in a lightweight scene). I indeed failed to include images, sorry for that. I have the solution now, I turned off multiple importance sampling in my image lights and the problem is gone. Those were mesh lights too (well, obviously) and the reason I didn’t realize that is due to my previewing on CPU (bc of unsupported GPU) and the preview was very slow, it appeared just some fireflies instead of the light itself. Thanks for looking into it though :slight_smile: