Image browser frame blank in 2.46 rc1

Hey folks, I ctrl-click on the load button of the background image windowlet and I get a blank frame/panel for an image browser, it’s empty except for the icons at the bottom. Is there a remedy or has this been fixed in a more recent release candidate?

Try accessing it through the Window Menu and see if it works like that. I have been using it since before November and it has always worked.

If you are on Vista, then it might be problem with that?

Using XP. I tried the window menu, same problem, thanks for the suggestion though. I thought it might be that I didn’t have python installed so I did that but still nothing.

Looks like the attached pic

Attachments


Looks like this bug has been fixed today. :smiley:

hey using 2.46 final this is how my image browser is too ( missing the actual selector)
is this still an issue ,or did I miss something ? cant see it in the tracker presently…

BTW (probably the wrong place to ask) does anyone know how I can invoke the image browser from the python UI if I have a button event to open the image selector?

edit: actually reading the release notes perhaps its not available from python yet…would be handy though :slight_smile:

so…can I put this bug in the tracker for 2.47? or no one else has this ?? ( using WinXPsp3 32bit )

I have this problem with the official 2.46 release. I’m running Windows Vista 32-bit. When I initially upgraded to 2.46, I downloaded the zip file and dragged the files into my Blender folder. No image browser. I have since downloaded and run the installer in the same folder, which doesn’t help.

However, when I install Blender clean into a new folder, the image browser works for that version… so I know it’s not a problem with my OS, or with this version of Blender.

Does anybody know what to do about this? Is there a way to fix the Blender in the original folder without losing my settings and whatnot?

The .B.blend is not forward compatible from 2.45 to 2.46. You will have to redo your settings, but if you want to keep your interface config, you can save a file as soon as you load Blender, and then load and set it as default in the new Blender.

Okay, thanks egan. I’ll try to fix it then.

Edit:
In case anybody else has this problem, I was able to fix it without losing all of my custom settings.
Navigate to your Blender folder, and open .blender;
rename .B.blend to something else. This will tell Blender not to use it, but you’ll still have the file;
open Blender. You’ll see a brand-new UI, with none of your preferences. File>Open, then find your renamed .B.blend;
Before you open it, make sure the “Load UI” button on the file browser’s header is disabled;
Click open. This will load your user preferences from your old .B.blend, but not your custom UI settings. Ctrl+Ukey to save these settings.

By doing this, I kept all of the preferences I had set in my User Preferences window – namely my custom themes and file paths, which would have been a pain to redo. I lost all of the preferences in all of the other windows, but I think the worst you lose that way is your custom screen layouts. You’ll also keep your default scene, world, material, etc.

Thanks again, egan.

I still have this issue. =(

…in 2.48 that is

When you say “still have this issue,” do you mean it never went away, or that it’s back? What have you done to try to fix it?