Image is always faded

I’ve just started using Blender in the last 16 hours… but it’s been very intense. I stayed up nearly all night and have been using it also through the day. Went through a 30-minute video tutorial and experimenting from there.

I’ve run into a challenge which is very frustrating now… and I think it’s terribly simple, but I just can’t figure it out. I’m using Blender 2.49 on Linux.

In my image, I have a gear and sphere (the gear is from a script I found online). The camera is placed above the plane that contains the two objects which are close to each other. I have set up two lamps, a “sun” lamp and an “area” lamp. The problem is very simple: whenever I render the image, the whole image comes out very faded. I’ve already created several images but I haven’t noticed this before, and I don’t know how to make it not be faded out. I even notice blender displaying the image for a blink of the eye nicely (deeply) colored, then it just redisplays it, and it’s as if there is a piece of white translucent plastic over the whole image.

Additional details: I’ve set the gear and sphere to be reflective using ray mirroring. I’ve also set the world background to be plain white (I want to cut the image and display it on a white page later).

I know this is a five second fix for you pros… help…?

I’ll be happy to send the file to a good Samaritan who can spare a minute. My email is “bland999” at “hotmail”.

Thank you in advance.

Try using a Hemi, Lamp, Spot, etc. instead of an Area lamp. Area lamps tend to be way too bright unless you adjust settings. I find it easier to just use another lamp type.

you can post your .blend file here.

I wasn’t sure whether it was proper etiquette to post my .blend file… so thank you for asking! Here it is. Just do a render as soon as you load. I get a washed out result.

Attachments

newGears.blend (264 KB)

Thanks for the suggestion, but I tried changing to Hemi for example, and no change: the image is still very faded.

Thanks for your feedback though.

What program are you viewing the image in? I know that the Windows Picture and Fax viewer will attempt to view a 64 bit image and will display it as very faded. Photoshop shows them as they should be.

Otherwise, I’d start just turning off lights till you get the fade away or the entire scene is black and start turning one on and rendering, and repeating till you discover what is too bright. You may also want to turn each light down as you go.

I’m using Blender itself - I just hit F12, and a window pops up displaying the rendered image.

I had two lights in the scene: a sun and an area lamp that I changed to a hemi (based on advice above). I got rid of the sun, and then got rid of the hemi as well. Oddly enough, the scene still renders but the two objects are just light gray silhouettes now - the image is STILL faded (they objects should be black, right?).

Attachments


I’m going to immediately suggest that you use version 2.5 and that you checkmark the Color Management box on the Render panel.

This will put you into the world of linear workflow, where the interface automatically and properly adjusts for the fact that, when you select a color-value “that looks right to you,” the RGB value that you obtain is a gamma-corrected value. Trouble is, the relationship between color-values and perceived color intensities is not linear (unless you check this box…), and so, the “addition and subtraction” operations that are performed by lights are all bolluxed up. Effectively, “1 + 1 is much greater than 2.”

The next thing that you need to consider is the total amount of light that you are actually projecting onto a surface, vs. the amount you are receiving from it. The defaults for diffuse + specular total to a value greater than 1.0, IIRC, which would mean that the surface is throwing more light than it receives.

I have learned to set up a flat-gray texture, then put that texture into the override texture input-box on a RenderLayer. This forces every color of every object to be, temporarily, “neutral gray.” This makes it much easier to determine how much light is falling upon your scene and where. You must get your lighting setup properly balanced first, before you attempt to do anything else at all.

I have also discovered that it is easier and quicker, in many situations, to treat light and (buffered, of course…) shadows as two entirely separate things. Light the scene the way you want with shadowless lights, then add “shadow-only spots” where you need them.

You have a white ambient colour mixed into your materials with 0.5 weight. Either go into the world settings and change the ambient colour to black, or turn the ambient setting down to zero for each material.

Even then, you have rather too much light and far too much total reflectivity from your materials: 100% diffuse reflectivity and 200% specular reflectivity and 50%+ mirror reflectivity means you are reflecting up to 3.5 times as much light as is incident on the surface! (OK, that’s a slight exaggeration, since specular reflection is parameterised differently, but still …)

Best wishes,
Matthew

Edit: I take back my previous statement, it looks like its even simpler than that. You simply need to lower your ambient light setting in the environment settings.

Go to your world settings and lower the AmbR, AmbG, and AmbB back down to zero or close to it.

Thank you very much to all of you for your very kind help. I had followed a very brief tutorial on how to make objects have a chrome effect, but I see that some of the suggested settings have some clear negative repercussions. Also there is no denying that while trying to get a plain white background in the ‘world’ I screwed up with the Ambient Light settings.

Thank you again.

If you need plain white background, render your object with a transparent background and add a white background in “post production” ( or in an “inactive” layer- no lights/shadeless)
Bye