Image plane blocking light coming from HDRI...?

Hi,

In my scene, I have a room with windows and have added image planes outside my windows(glass material) to use as a background image, I also have an HDRI to generally light the scene and some spot lights to light the inside of my room. I also want to emit light from the image plane to make it more realistic.

The problem I seem to be having is when I render my scene with the image plane in place it seems to be blocking the light coming from the HDRI.

Things I have tried so far:

  • Moving my image plane away into the distance

  • Turning Shadow off in the Ray Visibility - Helps but still blocks out the majority of light from the HDRI

  • Using a light path node

Does anybody have any ideas I can try? I hope this makes sense, I can post some photos if needed?

I will continue to research the internet in the meantime…

Thanks in advance!

Which render engine are you using?

Thanks for your reply, I’m using cycles render engine.

You want to light up the scene using image plane added as “images as planes” or light plane?

Every mesh (image as plane is a mesh) will block the light, unless you use transparency settings.

I have experimented with this.

(Eevee 2.93.6)

I have an HDRI as world light.

I add a sphere. I render and it is OK.

Then I add a cube and scale it so the sphere and the camera are inside the cube.

I render and everything is still ok, The cube DID NOT block the light.

thats a different render engine, this is about Cycles

I have managed to solve this problem by plugging the image texture into an emission node and using a mix shader to combine it with a transparency node. Thanks for all your help anyway!