Image plane quality

I’ve done some animation with image planes and have noticed that the end result is slightly blurred. I’ve tried every setting I can think of but can not get crisp image plane renders.

Here’s the original test image:


Here’s the same image rendered through an image layer in blender compositor. No degradation.

Here’s the same image mapped onto a plane in 3d view and rendered:

As you can see the image is quite notably blurry.

  • right click and choose view image to see full res. images *

The camera is positioned so to get the image plane to fill the image, there is undoubtly a slight misalignement from original image but it shouldn’t allow for this amount of blur anyway. To have image planes always slightly blurred is very much undesired.

Here I’ve composited original and image plane render into one image. original at top, image plane at bottom, divided at the red line. Have a look at the chalk lines in the middle where the blur is very obvious. (again, right-click and view full size image).

What can be done to get crisp, no blurry, image planes in Blender?

In the ‘Texture’ tab under ‘Image Sampling’ turn off ‘Mip Map’

Thank’s.
Didn’t work, same blur with MIP Map ticked off.

Are you using the ‘Import Images as Planes’ plugin?
This should give you an exact sized image plane to work with.
Any slight deviance in aspect ratio of the plane will case blurring.

Beyond that, turning off Mip mapping and Interpolation ( forgot to mention that ) will help with blender not resampling the image based on camera distance. You can see this by choosing different rendering slots and comparing with these options turned on and off

Because what you are rendering is an interpretation of the view of those pixels based on distance and focal length there will always be degrading of the image. It can be minimized but the only way to render an EXACT 1 to 1 pixel image ( and therefore no degradation) is to set your camera to orthagraphic view and tweak the ‘Orthographic Scale’ to get an exact alignment of the view and image size. Quite impossible to do manually and not at all practical.

If you need this image to be as crisp as possible, consider composting.

Yes, I’m using the import plugin.
Did try interpolation settings also, as well as different antialiasing etc.
Even othographic render gives this blur.

I’m doing cut out animation and is looking into moving my animating into Blender. Most of my artwork will be imported images. If I can’t get non lossy renders perhaps it not the solution for me. I do like Blender though and would very much like to solve this. I’ll investigate further.

As I need to animate the images compositing is not an option.

Hi,

Did a bit of playing around and turned off every option I could think of. Attached is my blend file and a render of the result. Can someone with a better monitor tell me if its sharp enough.

I am using the newest svn trunk version of Blender.

Attachments


bbc2_hd_tweeked.blend (962 KB)

Just noticed that there are color differences in my version, versus your original, so i probably should also have altered the color management option also.

Now that looks sharp!
Thank you!
I’ll look into what you’ve done to figure out what I need to fix in my render setup. Any ideas what it might have been?

Ok, tweaked color management turned it off and turned off some of the render features. Did a render and compared it to your original sharp version. They appear identical now. Attached the blend file and the resulting render.

Attachments


bbc2_hd_tweeked2.blend (963 KB)

Thank you very, very much!

I can’t really say what the cause was, I am guessing it was a combinations of things.

First I made sure to exactly scale the orthographic size of the camera to be 1, and made sure the imported image plane was exactly 1 blender unit across (so that i could be sure that 1920 pixel across was 1 bu for the camera). I turned off mip mapping, anti aliasing, and went to my user preferences system tab, turned off mip mapping and ansitropic filtering (though I think these should only effect the viewport and not final rendering). I checked the texture settings and i did the following. In image sampling for the texture I turned off mip map, interpolation, and the filter type i set to box and set the filter size to the smallest value (again I don’t think filter size should have an effect because disabling the previous options should mean this is ignored, but just in case :).

Id be interested to know myself exactly what the cause of this was, if I figure it out I will post, if you get it before me, let me know :slight_smile:

If you use the shadeless option, you are essentially ditching lights. You will not be able to use this in a lit scene.

This blurring is a known bug (I call it a bug) in the Blender Internal render system. I noticed the first time I used Blender years ago. It has never been fixed or addressed because it can not be fixed. When you project an image into a 3D space re-sampling must occur. It is how the Blender Internal render engine deals with the aliasing that crops up from the sampling system.

If you just want an image at it’s original size maybe you should consider compositing instead of rendering?

Atom thank’s for your insight.
Shadeless is another of my concerns with this as I probably would want lit scenes.
Would an external render handle images differently?
Also does blender need to add blur when resampling images? couldn’t some other method be used?

Again, this fullscreen image is just for testing. I’m animating image parts and have to render.