image plane texture not previewing

Hello all, I have a quick query. I have a jpeg stuck onto a mesh plane. It renders fine, but in the 3D view the texture doesn’t show? I have tried a PNG and TGA also. I am in textured Draw Mode, but nothing, just plain white. Any ideas?

Blender version 2.44 linux i386
intel GMA950 gpu

did you unrap the plane and assign the picture as a uv-map to the plane?

What Sebastian is referring to, is that the textured view mode shows what everything would look like, in GAME mode. Textures don’t show up in game mode unless they are UVW unwrapped. If I’m wrong, then the textured mode just doesn’t show any textures that aren’t UVW unwrapped.

You can have them show in Shaded Mode, when you use a plain image texture by subdividing the plane in Edit Mode; the more you subdivide, the more it will show. This workaround should not really be used though, as it adds tons of geometry. Better to UV map it and use Textured Mode.

Hi, does anyone know if that will change in the future? Before I used Blender I worked with 3D Max and here it was alway possible to preview textures on meshes, even though they weren’t UV mapped. It was very handy to get an overview of your textured scene…
In Blender I use the previewing possibility (Shift P), to get an idea of the scene when I don’t use UV mapping. But would be nice to somehow have direct feedback…

For my terrain which dosn’t look like much solid shaded, I just did a really basic uv unwrap and baked the composite terrain texture onto it.

Shaded mode will give you an approximation, but I think it uses temp vertex colours to do so so it’s not great. It’s also SLOW – you can look around after it computes but if it took a while DON’T try to move any object or it will stupidly try to update it in realtime and freeze for a while. (YMMV)

But yeah, textured mode uses the UV Image settings that aren’t connected to materials.

For what you’re doing, there’s the alt-v command which is supposed to auto-aspect a plane to an image loaded in the editor; but I’m not sure the exact requirements for making it work.