Image rendered black

Hi everyone :), i was doing a simple model of the HAL-9000 that i’ll probably post, but when i changed the texture of one of the components it turned black in the rendering… In the material and texture preview in the viewport everything is shown correctly, i tried re-UV unwrapping the model, deleting and re-opening the textures, making a new material, nothing worked, seems that blender doesn’t like the image, is a pretty big (3000x5000) .PNG ‘saved for web’ in photoshop, but the fact that is displayed correctly in the viewport is a bit strange… First time having this problem, Blender 2.71 on an i7 CPU.
Here a few screenshots:

The rendering preview is pure black, like when there’s no shaders applied, the cube is to prove there’s light in the scene

Again, pure black with the UV-Unwrapping shown on the right

Material preview shows correctly the image

Is there any lighting ? The info at the top of the blender window shows zero lamps

Supply a demo blend file that shows this problem

Don’t know how i resolved it… seems it was a material error, now it works fine, same lighting, same steps used to do the material, blender mistery x)

You know I am working with the same i7 and 2.71 version. (BTW to choose a GPU Render you need to got to Preferences > System to select) Where in my case, my quadro 4000 runs like a lame horse compared to using the CPU) Even on 2.68 I was getting conflicting views. Sometimes if I switch render engines and then go back. I have a current smoke animation one of the other senior artists here helped me with. Worked fine on the download for a couple of times and then now I cannot see my animation anymore. Albeit still there.
Being new, I ALWAYS think it’s me. Usually I am right. But try to close your file and re-open as that sometimes fixes things. You can actuate a switch and turn it off and that will cause a problem without Blender ever crashing. Hence the re-open before thinking it’s something you did and then undid but left Blender with a bug…