image sequence in GE

hi every1,
here i am again asking for some help ,this time i wonder how can i make the image sequence work for ge…any help is greatly appreciated!

Im guessing that you are talking about using a sprite sheet to make an animation?

You need glsl, for this method atleast.

Firstly, the image needs to be formatted like this:
So that each frame is in one picture.

It is easy to convert frames to this using the spritesheet plugin for GIMP:

Then, after you have opened blender, set the engine to “game”. This is important, otherwise the options wont appear.
Go to the “image editor” window, and press image, open and open the image.
After this, press “n” on the window, and an options dialog will appear.
Under game properties, press “animated” and “tiles” under the tiles settings, specify how many tiles wide and high the image is.
If you used the provided gimp plugin, you will only need to change the X value, as the plugin puts all the images in a straight line.
then set the end frame to the last frame. Finnally, press the button under “image” which says fields, then the option “upper first”.

To get this animation to play, you create a new material, and under the texture settings, select image, then press the little shape NEXT to open, and select the already opened image.

You can then map this to uv, or generated, it does not matter. When you start the game engine, the animation will play…

hi smeagle,
thanks for ur reply, i tried exactly the way to tot and it didnt work,the animation wouldnt play …what am i missing?
do u want the file to apply that for me?

It is easy to convert frames to this using the spritesheet plugin for GIMP:

new one, thanks.

Things that could potentially go wrong:

The method I posted was for 2.5x If you are using 2.49, the method may be different…

Make sure that the graphics mode is set to GLSL. This can be found in the “render settings”, when the engine at the top is set to “Blender Game”

Set the speed of the image to something greater than 1
make sure that the “animated” and “tiles”" buttons are ticked
set the start frame to 0, and the end to the total frames-1

If it stil doesnt work, you can post the file here, and Ill try get it to work

I also just realised that you do not need the “fields” of the image set to upper first, just untick the button, and leave it blank :stuck_out_tongue:

Hi Smeagle thanks for ur support again!
I tried and it didnt work so im sending u via PM the file ok?
thanks in advance,

Hello, can someone post a .blend file that works? I tried this out and had a couple of problems. 1/ it only cycled through what looked like the first 5 images. 2/my plane was textured with 5 cubes in a row verticaly.
Unfortunately I’m at work right now and can;t upload my problem file. I’ll take another stab at it when I get home, but if someone can put up a file that works, it might help to deconstruct the problem.

hi Molino,
do u want that to work for Game engine or just for animation? coz that doesnt work for GE,if u want that it works for animations u have to edit the files(pictures) in sequence such as pic_000001,pic_000002 something like that ,if u need help just post the file and i fix it for ya…

I’m confused… I just read over Smeagle’s post (2nd one from the top) and it says at the end “When you start the game engine, the animation will play…”.
Plus… this post is in the Game Engine section… soooo… you’re saying his method wont work in the game engine?
Me no understand.
P.S. I’m home now… so I’ll re-try his method in the morning and if it goes wrong again, I’ll post my blend file.

The major things which sound like problems in your case are:
In my instructions, I said to turn on fields, and upper. I have since realised that this is not needed, better leave it off, I dont know what it does :wink:

Is the image uv mapped onto it? THe issue which Gacktoactivity had was that the game engine has some sort of glitch, so the uv mapping was slighly off

Is the game set to glsl materials? And does the objects material have the texture selected and set to “uv mapping”

WHat does the cube actually do when you play the game? Does it change at all?

Sprites.blend (366 KB)
IIIIII just don’t know whats wrong. So here’s my file. If you can get it to work, I’ll name my next child Smeagle. :wink:

Which version of blender are you using?
It works fine on my computer, the only problem I can see with it is that it is playing the order of frames slightly off.
To fix this, I would suggest arranging the frames in a straight line, it makes it simpler, as I am not sure how Blender plays the frame order.

Hi there, thanks for taking a look at the file.
I forgot to mention that I got it to show just the one box image. Not sure why it wasn’t working before.
The only problem was the playback animation was all messed up. So what you’re suggesting is that instead of using a 5x6 “grid” of images… use a straight line so it would be a 30x1 row?
I’ll try it out.

Follow up on this.
So I tried out the Gimp plug in and it created my sprite sheet in a single horizontal row. I followed the instructions above and… it worked!
This could come in really handy with Blood splatter.
Thanks for this.

Save n**2 images as layers in GIMP. Use GIMP “Mozaicize”, then vertically invert.

You can run up to 11 x 11 = 121 frames.