Image sequence rendering with shadow artefact

Hi, I’m having an issue when outputting an image sequence. there is this weird ring shadow in the animation and it doesn’t exist in any of the individual png files. I’m outputting as
3840X3840 60 fps
File Format - FFmpeg
Container - MPEG-4
Video Codec - H.264
I’ve been trying to fix this for hours. Any help would be greatly appreciated

If you are just using the sequencer, I would turn off the Compositor and look at “Dithering”
image
Did you try AVI Raw?
image
Blender shouldn’t but maybe it applies Color Management twice? You might try there:
image

Thank you for the tips @Boder, I really appreciate it
I played around with the dither (set to 10) and gamma (set to 1.5) and it fixed up the shadow artifact.