Image texture problem (cycles)

Hi all

I am having a problem getting an image texture to display within Cycles. Attached is the .blend file. It seems to be happy for some images, but not others. Format does not appear to be a problem - I got a different jpeg to work. Size does not seem to be a problem - I got a bigger image to work. It is peculiar that it renders with the overall colour of the image, but no detail.

Any help is greatly appreciated

Cheersimtextprob.blend (1.57 MB)

On opening your blend file.

By default the vector input for a texture node is UVs unless there is a texture mapping node to set it to something else. You don’t have a texture mapping node so its using the object UV coordinates but you have not UV unwrapped the object ! It therefore cannot display the texture in the render.

Either set some other texture coordinates or uv unwrap the object

Simply unwrapping the object gives the attached render

I have the same issues.
Some JPG open and texture and some don’t.
The one that didn’t when opening and looking at the properties in GIMP, said it was an Adobe CS5 generated jpg.
I then exported it out of GIMP into a JPG and it then worked.
Open yours in GIMP and export as the same format and see if that helps.
May be a bug of some sort.

Thanks for the replies.

FloridaJo: I’ll keep that in mind!

Richard: That sorted it - I just gave it the ‘object’ texture coordinates. I could’ve sworn I tried that before, but obviously I was wrong!