Image texture shows background

Hello everyone,

I’m trying to use an image as a texture and its working fine except that it is showing a background even though I used a photoeditor to make the background transparent and saved it as .png). I’m applying the image as a texture in blender by creating a new material with the desired faces selected and creating a new texture and then loading the png image.

Any ideas?

Thanks

Make sure you have loaded your image as a texture in your material, and set it to use alpha. Also, make sure you have enable z trans in your material settings and you might need to set the blend mode to ‘multiply’. Also when setting the image as a texture, under hte texture panel click ‘premul’ to ease the edges of the texture transparency, and make sure to change from ‘oro’ to ‘uv’ if you have uv mapped the image to the mesh.

Thanks craigomatic, I’ll give that a try.