Image texture stretched out, help!

I am making a scene in blender of a glass which is filled with water. I want to render this glass with cycles. I have a background with an emission effect and to not make the background too boring I added this Image texture to the back plain:



But when i edited the material of the plain so the color would be an image texture and the surface would be emission. But instead of getting a nice glowy background I got this stretched effect.


Anyone know how to fix this?
Thanks in advance.

The idea for this glass comes from this tutorial on blenderguru:
http://www.blenderguru.com/videos/create-a-realistic-water-simulation/
I am new to blender so please don’t shoot me if this is a stupid question.

Hi, you can try to UV unwrap the background and then set the vector to UV. U can also adjust image position and size, when you use UV editor. You can also import the background image as a plane - first go to file -> user preferences (ctrl + u or CMD + ,) and then addons -> check [x] import images as planes. After that you go to file -> import -> images as planes.

just off the top of my head I would suggest…
So to check this … Tab into Object mode > Select your plane > on the bottom tool bar select 3D manipulator (the 3 legged triangle icon thingy) > just to the Right of this there is a pull down menu that probably says ‘Global’ set it to say say ‘Local’ … now look at your plane… which ever direction the Blue Arrow is pointing is the ‘Z’ direction and is the direction that your image is currently facing…
If you find that the ‘Z’ is pointed twords an edge on your plane… then >
Tab into Edit mode > hit ‘A’ to select all > then hit R to Rotate > X to limit rotaton on the ‘X’ axis… (you may have to use the ‘y’ axis…) > then type in 90 (for 90 degrees rotation… that should fix it…
now if you want to Rotate the plane in a different direction make sure you rotate it in Object mode not Edit mode…

but this may not be the problem…