Image transparency obscures objects behind/recieves light

Using image planes with alpha.
If Transparency is set to Mask in the Materials tab of the image plane then objects behind the plane is obscured even if they are in the alpha area of the image (they get masked).
If Transparency is set to Z the objects behind is not clipped but instead the alpha on the image recieves lights and shadows…

How can I get a clean alpha that recieves no light and lets me see whats behind it?


Sorry for bumping but I would really need an answer to this.
Except rendering every plane separately and comping everything together is there anything I can do to get clean alphas?
Is this to be considered a bug (alphas shouldn’t cast shadows)?

The transparent material (with the alpha texture) needs “Alpha Transparency for Specular Areas” set down to 0.
The material of any object behind the alpha textured plane needs to have “Receive Transparent Shadows” enabled:

I already had those settings.
What seems to work is unticking Cast Buffer Shadows for the transparent plane. Z-buffered alphas doesn’t seem to cast shadows then (or recieve them it looks like, have to investigate whats going on here…).