Image Won't Load in Mac

I was mucking around with the latest Mac version of 2.43 for PowerPC, and found that it won’t let me load images either as textures or as Backbuf. No type of image at all. I tried with the Python 2.4 build and then updated my Python to 2.5 and tried the 2.5 build. Using OS X 10.4.9. Is this a bug or am I the only one having this trouble? Works just fine on my Windows computer, but I do a lot of my practicing with new features on the Mac, so I’d like it to work. Any suggestions?

In OS10.3.9 I sometimes find a texture image has to be “loaded” twice before it shows. Also, if I RMB select (CMND-CLICK) the file in the browser then ENTER, the image field shows blank (IM: ) and the path field just shows the parent folder - and no image loads.

MMB (Option-click) gives no result.

To have any success I have to LMB the filename then ENTER.

Hope this helps.

Some earlier versions of Blender had that balky load. Usually two or three tries would get it to “take”. Now, nothing works. I use a three-button mouse with my Mac, generally with identical results to working in Win, but even trying the mouse/key combinations doesn’t let the image load. Thanks for the feedback, though!

OK, after unsuccessfully trying to find any information on the problem, I posted it as a bug.
Whoooo…after my ears stopped ringing from Ton’s response, I tried his solution. :wink:
It turns out it’s an OpenGL issue. Go figure. If I set my screen depth to “Thousands” of colors, images load fine.
Huh? I thought OpenGL was just a library for screen display. Since when does it affect how programs can access other data?
Hope this helps other people with the same difficulty.

ack! i used to be able to load images but now i too am unable. i’ve tried older versions of blender, as well reducing the screen colours and resolution, but nothing is helping.

nothing has changed on my system hardware wise, and while it is an ati card, why would it just stop working if it did work previously? the ati mac driver hasn’t been updated since the end of 2005, so that hasn’t changed either.

EDIT: i just discovered that if i open up a blend file from before this problem started… all of the image textures it references load fine, and furthermore i can go to file>new and start working on a new project from there with images loading properly. i guess this is a work around of sorts, but does anyone know what could be the root of this issue?

EDIT2: the above work around proved ineffective. when i tried to re-open a newly created project all my image textures displayed the error “Can not get an image”

It’s all a bit of a mystery to me but your Blender appears to be referencing two different files there


This suggests there’s some duplication going on at some point. Try putting an image in a brand-new, empty folder and loading that (just a wild guess).

It also isn’t displaying any path to the file. My (Mac) Blender image file path shows something like:

//…/image_folder/doorway.JPG (but maybe you’re storing your images in the root directory?)

well the problem seems to have gone away. i opened up the ati control panel, created a custom 3d settings profile for blender and set it to performance-quality slider to max quality. now everything works.

oh ati, what a fickle beast you can be. i’d go for an nvidia card if i wasn’t stuck on powerpc.

thanks for the suggestions AndyD, i hadn’t noticed the multiple file referencing, so i will keep your advice in mind if this problem ever resurfaces!


I was having the same problem loading both background image and texture images (Blender 2.44, OS X 10.4.10). Making sure that the “Relative Paths” button is unpressed in the file browser solved the problem for me.
None of the above solutions worked for me, so i thought i would share.

That worked also in my case.

I tried with Blender 2.44 on OS X Tiger 10.4.10 and it had the same image loading problem, I have been able to fix it just following the above tip (uncheck “relative Paths” in the select file window)