Import Blend file into 2.49 results in hang/crash


I infinitely prefer using the newer interface of the v2.6 series Blender, but to create the Kuju .IGS files I need, the only exporter I know of only works on v2.49. Until recently I found I could develop in 2.62 and then load into 2.49 for export and it worked ok - I got a complaint about losing animation data, but I’m not using animation.

I’m developing a model of a large building and had been using that route but recent changes caused 2.49 to hang indefinitely/crash on loading the .blend file. The changes were to UV map the structure using U&V-repeating tiles rather than singly mapped (& to do this I found I had to assign each set of faces using a given tile texture as a separate object).

Does anyone know why this might be happening, and importantly of a way around it?


[[I can export from 2.62 into 2.49 using a Wavefront .obj file - but then the scale is messed up, and the exporter then hangs when trying to “map blender to IGS structures”, which makes me think it’s not a good route!

I have also tried importing first into blender 2.55, saving again and then into 2.49, and also importing into 2.63 and saving using the “legacy mesh” option. Neither makes a difference to the result.]]

In 2.49b, instead of File -> Open , try to click on File -> “Append or Link”
In the browser, browse to the blend and select it, it will bring a list , click on “Object”
Select all the objects that are part of the model you want to import, do not import the camera and light.
Once done, click on the “Load Library” button in the upper right corner of 2.49b

Hopefully this will work (be sure to have saved the model with “Legacy Mesh Format” in 2.63 or you’ll lose all the faces)

Thanks for the info Sanctuary… I can import the objects fine - which is good - but the texturing is lost. I tried explicitly importing the textures, meshes and materials but that didn’t help (and the IGS exporter complains about unbound material indexes). Do I have to retexture things in 2.49?