import error - no module named videotexture at runtime

The video texture module is working in my blend file but when I save to runtime I get an error saying

Import Error: No module named VideoTexture

My deadline is coming up fast. Does anybody have any idea what the player can’t find the VideoTexture module? I’ve searched high and low through forums and can’t find any solution.

I’m using Blender 2.48 SVN 17349

hmm, try posting it or PM’ing the video texture creators directly. Is the Module in the same folder as the blend? Did you pack the files?

Hi! I get the same error message as you… Did you fin a solution? I’m also using 2.48, and the error occurs both on my mac and windws…

I think it’s like this:

When you run the module from blender directly it checks the blender folder, which should work.
When you run as a runtime, it checks the folder that the runtime is in.

Copy the module from the blender folder to the folder that the runtime is in and distribute the module with the runtime.

I hope that helps…

EDIT:
Moguri corrected me; I don’t have experience with the video texture module, I was just making assumptions. As a Blender internal module, it should work the same as a runtime as it did when it was used in blender.

The module is compiled into Blender just like GameLogic, Rasterizer, and GameKeys. You won’t just find a VideoTexture.py laying around. However, I still don’t know what the problem is.

The problem doesn’t only occur when i save as runtime, but also when I try to render inside Blender.

Therefore, the demo of videotexture on the Blender-pages won’t work…

http://wiki.blender.org/index.php/GameEngineDev/VideoTexture

Please help!

The problems occur both when saved as runtime, and when I try to render in Blender… So the videotexture demo at Blender homepage doesn’t work…

What version of Blender are you using? The VideoTexture module is not in an official release, it’s only currently available in the SVN.

As Moguri says, VideoTexture is not in an official release and you will both a blender and a blenderplayer executable from SVN.
If you do that, VideoTexture is available in the runtime.

how do i get it from the SVN? can anyone give me a link please? thanks!

I am having the same problem: video plays under blender, but not if I use the player or the runtime.
i am using blender 2.49b
Console says there is No module named VideoTexture

has someone found a workaround ?
Thanks in advance.

same problem here
I’m using Blender 2.49b on Linux
it seems a blenderplayer bug

I have tried to make a runtime with windows ( virtualbox and Linux), and it works.
i did not even change path of my video (//./Datas/videos/1.avi) ( 1 directory up and in another subdirectory)
It should be …\Datas\videos\1.avi, but blender understands the linux path, under windows.
This is great !

This means that the 2.49b package downloaded for linux 64b on blender.org does not include the videotexture module( I’m using a 64bits system.)
The only debian package I have found is a 2.49a.
If someone knows where to find the 2.49b debian full package !

I suppose that many Linux blender men and women have this problem.

i’m using 32bit version and the videotexture module isn’t included too.

Talk about reviving a dead thread. o.O

Blender needs to be built with ffmpeg support for the VideoTexture module to be built (and therefor accessible).

@ Moguri: I shall search how to, but:
it works fine under Windows, both blender AND player (2.49b)
it works fine under Linux, only Blender.
I’m not a specialist, furthermore non english speaking, but in my opinion, ffmpeg support should ALSO be built in the player of the Linux package.

ffmpeg IS installed at home - how can I compile an ffmpeg support in the player only ? as I said, I shall search.
I someone is in touch with blender developpers, please ask them to add this feature in 2.5 future release - thanks for those that are not “geeks”

@ Moguri:
I’m using the .deb package from blender.org, where is stated it’s compiled with ffmpg.
Videotexture works just fine inside blender but it fail on blenderplayer so I guess the player was compiled without ffmpg by mistake.

I’m having a similar problem. If I run my script inside blender I get the error “No Module named VideoTexture”. I have Blender 2.49a on a mac by the way.

I solved my problem:
I downloaded blender 2 49b from here:
http://www.getdeb.net/release/4734

Now, my runtime plays videos.

Well, I suppose all people using ubuntu should download packages form the above address, not from the blender download page.

Hope zoiba, Duo Oratar and the others will succeed as I did.

(I have been unable to make blender from sources, I got errors, so I’m really happy with the above Deb package)