Import from Max as exported .3ds gives jumbled objects

I am using a newish version of Max and blender 2.41 and 2.25 (so I can VRML97 back in).

When I export out of 3DSMax as .3dS when I import that file into Blender. It reads in fine and has materials called out, but the objects have been shuffled around. All abjects look to be coorect just rotated and translated into the wrong position.

I’ve tried this on a dozen models with same result.

Anyone else have this problem and was able to fix it.

I tried bringing in as .OBJ and it works but is very, very slow.

Hey, I maintain both 3ds and obj importer, can you emails me the example files?

cbarton
at
metavr.com

It seems like the errors start with the way 3DS Max is exporting the .3ds.

Even when I read the .3ds files it back into 3DS Max some of the pieces have been slightly shuffled. But not as bad as when I import into Blender. Than it really goes batty and shuffles the pieces alot more.

I will do some research myself to see if I can get a better export from 3DS Max.

I know this is an old thread, but I was just downloading some Star Wars models from SciFi3D and came across the exact same problem in 2.42a. Very annoying, especially if you don’t know exactly where everything is supposed to be. (As is the case in the star destroyer I downloaded.) Kind of like putting a 3D virtual jigsaw puzzle together…

[Edit] If you need an example file, the aforementioned star destroyer can be found here.

The error is not in how Max exports the 3ds but in how Blender reads it. I’ve had exactly the same problem “aobjects” describes above and after trying several things I found out that opening that same 3ds file in Unwrap3d (or ac3d) will make the meshes show up properly orgnized, and resaving it will give me a good 3ds for blender. Or, as mentioned above, you can export to obj but materials and UVmap coordinates work great with the 3ds format, which makes it attractive to work with blender. The only pain is the 65k poly limit :frowning: Dunno why resaving the 3ds file in another 3d app prior to importing it into blender fixes it not showing all messed up.

Here it is in a clearer way:

  1. 3ds exported from max directly imported into blender:
    http://afecelis.gdlib.net/Blender/building01.jpg
  2. same 3ds file, imported into ac3d (or unwrap3d):
    http://afecelis.gdlib.net/Blender/building02.jpg
    3.Resaved 3ds file (in ac3d) imported into blender:
    http://afecelis.gdlib.net/Blender/building03.jpg

Okay, assume I can’t open it in another application…

I’d say try opening the 3ds file in wings3d (which is free) and resave it to something you can import into Blender; but I just tried it in wings 0.9832a and it breaks :frowning: (dunno if another version may load the 3ds).
But since the discussion is about bringing models form max into blender, I’d say get the free obj exporter for max6 here:
http://www.habware.at/max6/Max2Obj6.zip
and export to obj directly. Other versions of the exporter here:
http://www.habware.at/ente.htm
Geometry loads up ok, but oriented weirdly (needs to be rotated exactly 90 degrees around the X axis) and needs to be “set solid”
http://afecelis.gdlib.net/Blender/building04.jpg

just found a 3ds2obj converter, but it seems to be for linux:
http://www.linuxgraphic.org/section3d/blender/pages/ressources/utils/util-ang.html
and this lady here, says she’s got a fixed 3ds2obj converter for blender, but there´s no link available :frowning: :
http://www.sarah-f.com/other/

Just compiled a version for windows but it doesn’t output anything :frowning:

Yikes! Objects are even more jumbled in Wings 3D than they are in Blender…:frowning:

I just downloaded a 14-day trial version of ac3d and that’s not working either. Perhaps this will be fixed in the next Blender release.

That’s weird LOTRJ. AC3D trial is a fully working-time trial version. Could you post your 3ds model exported from max to give it a try?

I posted a link to an example file in post #4.

Ok, got the file you mentioned. I downloaded the 3dsmax verison to do all the process and there are several things.
1st. of all the file comes with a whole bunch of unnecesary info (lights, helpers, dummies, etc), so I started by erasing all this info.
2nd. It’s quite a complex mesh; it totally surpasses all the limits in the 3ds format. Check the summary info:
http://afecelis.gdlib.net/Blender/3ds/suminfo.jpg
It would be easier to model it simpler and add a discombulator (greeble) modifier. So it’s a 3ds that will be bound to errors. But I exported it anyway.
3rd. Opened it in Ac3d, and for my surprise it wasn’t that bad. Only the tail was misplaced:
http://afecelis.gdlib.net/Blender/3ds/ac3d01.jpg
4th. Moved the tail into place and re-exported to 3ds:
http://afecelis.gdlib.net/Blender/3ds/ac3d02.jpg
5th. Imported into blender and everything was ok.
http://afecelis.gdlib.net/Blender/3ds/imprerial_blender.jpg
if you need the blender file grab it here:
http://afecelis.gdlib.net/Blender/3ds/imperialstar.zip
hope it helps :wink:

Please download the blender file again. Just cheked it and had a ton of double vertices. Jut removed them. Same DL link :wink:

Um, the entire bridge of the ship is missing. Anyway, much smaller files have failed as well. I really appreciate your helping me with this.:slight_smile:

http://img165.imageshack.us/img165/3032/sternzerstrergf7.th.jpg

[Edit] The sides of the ship are missing too.
http://img103.imageshack.us/img103/1006/sidegonebe9.th.jpg

darn! sorry, I had barely noticed the errors as I’m not much of a scifi fan. But I still hope this exercise we made was worth the try.

I also exported the original file from max to obj and to Unwrap3d. Let me check those to see if the missing info is there, but since the dilemma was with 3ds I gave it a shot! :wink:

I confess.

I’m a coder, and have no experience with 3d modelling. I’m in a bit of a bind though. I own this 10 year old game, and want to render a bunch of the in-game models so I can redo my website.

Anyhow, I’ve got a bunch of .max files – and I’d like to try to import them into blender. When I try to import them, I get an error, and the console says something like this:

In BPY_call_importloader(name=C:\data\NtankArt\Models\bomber11_S.max)

But that’s it… the UI tells me that it can’t load the file, and I should check with the console.

Of course I noticed the console saying something about not finding Python, so I’ll reinstall a newer version of Python and see if that helps. But does anyone know if blender can import .max files?

Thanks.

PS: www.wulfram.com is the game I own, and want to render the old objects for…

I don’t know if this can help in anything, but 3ds files coming from Autocad import perfectly in Blender… Since Autocad and Max are made by the same firm and usually import/export perfectly between them (both read/write dwg format), it is another good way to translate. Of course Autocad is not free (far from that, actually), but Max neither…